Documentation/3.5

From SlicerWiki
Jump to: navigation, search
Home < Documentation < 3.5

For the latest Slicer documentation, visit the 4.6 page.

Nightly 4.6 4.5 4.4 4.3 4.2 4.1 4.0 3.6 3.5 3.4 3.2 ALL VERSIONS

Main GUI

Main GUI

Modules

  • Please copy the template linked below, paste it into your page and customize it with your module's information.

Slicer3:Module_Documentation-3.5_Template

  • See below for info to be put into the Help and Acknowledgment Tabs
  • To put your lab's logo into a module, see here

Please adhere to the naming scheme for the module documentation:

  • [ [Modules:MyModuleNameNoSpaces-Documentation-3.5|My Module Name With Spaces] ] (First Last Name)

Requirements for Modules

  • The module is feature complete, it does everything that it advertises it can do
  • The module has a test. See here for more information.
  • Module has documentation on the Slicer wiki. Please use the template provided here to structure your page. Please keep in mind that our users are not computer scientists with a background in computer vision.
  • Please add a pointer to the documentation on the Slicer wiki to the the Help tab of the module. See the Editor module in Slicer for an example.
  • The contributor (and their manager/advisor), the lab (with labs/institution logo) and the funding source (with grant number, logo optional) are listed in the Acknowledgment tab of the module. Please see the Models module for an example. The people listed in the acknowledgement will be the primary people for support and maintenance relative of the module. See here for more information.
    • Style Guide: All acknowledgment icons should be 100x100 pixels, preferably in png format.
    • Accessing logos: Icons for BIRN, NAC, NA-MIC and IGT are included in Slicer3/Base/GUI//vtkSlicerBaseAcknowledgementLogoIcons.cxx/h and resources for them are in Slicer3/Base/GUI/Resources/vtkSlicerBaseAcknowledgementLogos_ImageData.h. The API for vtkSlicerModuleGUI provides access to these icons.
    • Adding logos: Please add additional image resources and logo icons to these files as required in order to promote shared use (and to prevent duplication in the code.)
  • Many modules are better suited to be downloadable extensions. The same module creation guidelines apply, but the actual implementation is done outside of the slicer source code repository.
  • Follow "Rons rules for tools"
Examples for the Help and

Acknowledgment Panels

SlicerHelpExample.png
SlicerAcknowledgementExample.png

List of Modules new to 3.5

List of pre-existing Modules

Core

Specialized Modules

Please adhere to the naming scheme for the module documentation:

  • [ [Modules:MyModuleNameNoSpaces-Documentation-3.5|My Module Name With Spaces] ] (First Last Name)

Wizards

Informatics Modules

Registration

Segmentation

Statistics

Diffusion

DWI

DTI

Tractography

IGT

Filtering

Surface Models

  • Modelmaker (Nicole Aucoin)
  • Grayscale Model Maker (Bill Lorensen)

Batch processing

Converters

Slicer Extensions

Extensions for Downloading

Introduction

Slicer on NITRC
  • Slicer Extensions are a mechanism for third parties to provide modules which extend the functionality of 3d Slicer.
  • Some of the extensions do not use the Slicer license. Please review carefully.
  • For a subset of extensions, you can use the extension wizard in Slicer to find their webpages and to install/uninstall individual extensions. In case of problems with those modules, please talk directly to the developers of the extensions.
  • The version that is available through the extension manager is chosen by the developer of that extension

We are using NITRC as the primary repository for contributed extensions. As a general rule, we do not test the extensions ourselves. Use them at your own risk. Click here to see a listing of Slicer 3 extensions on NITRC.

Extension manager dialog box

To add extension modules to an installed binary of slicer:

  • Use the View->Extension Manager menu option
  • The dialog will be initialized with the URL to the extensions that have been compiled to match your binary of slicer.
    • Note installing extensions from a different repository URL is likely to be unstable due to platform and software version differences.
    • You can select a local install directory for your downloaded extensions (be sure to choose a directory with enough free space).
  • Select the extensions you wish to install and click to download them. Installed extensions will be available when you restart slicer.
  • To turn modules on or off, you can use the Module Settings page of the View->Application Settings dialog.


  • Extensions are compiled as part of the nightly build. In order to have your extension compiled nightly and made available to end users, please contact the Slicer team. For explanations for developers see here

Installation

  • Click on the icon to start the extensions wizard

Extensions Wizard

Listing of available plug-ins

  • VMTK (Daniel Haehn)
  • ABC (Marcel Prastawa)
  • Modules:HAMMER (GuorongWu, XiaodongTao, JimMiller, DinggangShen)

Extensions Contact List

This is a first pass list of extension authors; more to come!

ABC Marcel Prastawa prastawa@sci.utah.edu
EMFiberClusteringModule Mahnaz Maddah maddah @nospam@ ge.com
BRAINSROIAuto Greg Harris gregory-harris @nospam@ uiowa.edu
Bubble Maker Carlos Mendoza carlos.sanchez.medoza @nospam@ gmail.com
Hammer Registration Dinggang Shen dgshen @nospam@ med.unc.edu
Lupus Lesion Mark Scully mscully @nospam@ mrn.org
VmtkSlicerModule Daniel Haehn haehn @nospam@ bwh.harvard.edu
Vmtkin3DSlicer Daniel Haehn haehn @nospam@ bwh.harvard.edu
BRAINSFit Eun Young Kim eunyoung-kim @nospam@ uiowa.edu
ARCTIC Cedric Mathieu ced.mathieu @nospam@ gmail.com