Slicer:Slicer2.4 Release Notes

From SlicerWiki
Jump to: navigation, search
Home < Slicer:Slicer2.4 Release Notes

New Features in Slicer 2.4

Slicer 2.4 has many new features! In addition to numerous bug fixes and other improvements, the list here highlights most major some new features in Slicer 2.4. Please also note that many of these new features are still being developed and will be improved in future releases, so you may encounter some unexpected behaviour. Please report it to the Slicer User's mailing list.

Updates to existing modules:

  • Base: added the Modules menu at the top level to give a hierarchical listing of the current modules
  • EM Segment: major improvements added to the algorithm
  • View: when you close a scene via the File->Close option, the viewing defaults will be reset to out of the box values. Added a "return to defaults" button for the light settings.
  • Endoscopic: added support for flat models.
  • vtkFreeSurferReaders: moved to their own module, can load Freesurfer colours files now, as well as more surface files, and MGH files as well

Additional functionality:

  • Support for time series data (vtkIBrowser, vtkBXH, vtkFMRIEngine, vtkFSLReader, MultiVolumeReader)
  • Support for Analyze format data (vtkAnalyze, vtkCISGFile)
  • Support for automatic rigid intensity registration (iSlicer, vtkRigidIntensityRegistration)
  • Support for DMTRI and Tensor data (vtkDTMRI, vtkTensorUtil)
  • Support for metric mapping (LDMMViewer)
  • New processing routines (vtkAffineSegment, vtkImageSmooth, vtkMIRIADSegment, vtkRealignResample, vtkSubVolume, vtkCorCTA))

Building

You don't have to build Slicer yourself to use it. If you want a precompiled version, go here.

To build slicer from source, see Slicer:Slicer2.4_Building

  • Windows
    • distributed versions are built with Microsoft Visual Studio .NET in release mode (note that there may be some problems compiling with .NET 2003)
  • Solaris
    • We are building using gcc version 3.0.3.
    • If you are compiling using the genlib and cmaker scripts, after you run the cmaker.tcl script, the build for vtkFMRIEngine will fail. To build this module, you will need to download the gsl libraries from Xythos and run cmaker.tcl again.
  • Linux
    • We are building using gcc version 2.96 20000731
    • If you are compiling using the genlib and cmaker scripts, after you run the cmaker.tcl script, the build for vtkFMRIEngine will fail. To build this module, you will need to download the gsl libraries from Xythos and run cmaker.tcl again.
  • Mac OSX
    • These patches must be applied to compile on OSX.

Installing

No special installation is needed -- simply unpack the distribution archive and run the platform-specific executable at the top level (for example, slicer2-win32.exe for the Windows build). The slicer distribution contains all the needed support libraries and has been tested on a variety of system configurations.

Base Operations

  • Linux

If you are having problems running Slicer over an ssh connection with X forwarding, the problem may be that you don't have the appropriate OpenGL libraries on the machine you're sshing from.

Modules

As a research platform, Slicer includes several modules that are not yet fully implemented, but which the developers still felt were far enough along in functionality to provide utility for the community. As such, you may find that some operations do not behave as expected, particularly where they interact with other slicer functions. Please let us know about these issues by filing appropriate bug reports.

Reporting Bugs

Please report bugs for slicer version 2.4.x. here.