Slicer:Slicer2.4 Getting Started

From SlicerWiki
Jump to: navigation, search
Home < Slicer:Slicer2.4 Getting Started



THIS VERSION IS STILL SUPPORTED BUT FOR THE NEWEST VERSION FOLLOW THIS LINK TO SLICER 2.5 Slicer2.5 Getting Started

Download Slicer (This is what users should download)

Download and unpack the appropriate archive for your platform (Windows, Solaris, and Linux) from here.

Follow the Tutorial

To learn more about using Slicer, refer to this Slicer tutorial (also available in powerpoint format).

Get Sample Data

The following data is for use with the Slicer tutorial:

Unpack this archive, launch Slicer, then in Slicer use the File->Open Scene... menu to open tutorial.xml. Click and drag in the 3D window to rotate the head. Use the sliders above the 2 D slice windows to scroll through the MRI volume in the axial, sagittal and coronal planes.

Additional data to use with Slicer

Build Slicer (This is for developers)

If you want to build your own copy of Slicer 2.4 from the source code, follow the instructions here: Slicer:Slicer2.4_Building

Installation

You can run the toplevel slicer executable from any directory, but if you want to install it as a system-wide package we suggest the following methods:

  • Unix/Linux:
    • place the slicer2 distribution directory in /usr/local/lib/slicer2.4
    • place a symbolic link in /usr/local/bin pointing to the executable for your platform in the distribution directory
  • Windows:
    • there is no windows installer, so you may put slicer in any convenient location. You may wish to put a shortcut to the slicer2-win32.exe on your desktop.
  • Mac OS:
    • No installation suggestions currently


Notes for Mac OS X Users

We haven't 'officially' supported the mac platform until now because of variations we've been seeing in the graphics support on different machines (ATI vs. nvidia cards, etc) and that's been hard to troubleshoot. But we've made some changes and now have a version that we think is working pretty well. The software is here (precompiled, no installation needed).

To run it, you need to have the X server and from an xterm run the slicer2-darwin-ppc executable at the top level of the unpacked archive.

If you want to customize the X11 Application menu to launch slicer, you can use a syntax like the following:

xterm -e /Users/pieper/slicer2.4/latest/slicer2/slicer2-darwin-ppc

Other notes on building and running on the Mac are at Slicer:Patches_for_the_Mac

Note that slicer relies on the X11 system and must be launched from within an xterm. More information about X11 on the mac.