Documentation/4.2/Developers/Build Instructions/Prerequisites

From Slicer Wiki
Jump to: navigation, search
Home < Documentation < 4.2 < Developers < Build Instructions < Prerequisites

For the latest Slicer developers documentation, visit the Nightly page.


Please check that the following tools are installed on your machine.

Required tools and libraries



Linux

Ubuntu

For Ubuntu 13.04 note that you must download or install the standard cmake from [1] because the version of cmake that comes with Ubuntu 13.04 cannot be used to build slicer.

  • Ubuntu users, just type the following line in a terminal
sudo apt-get install subversion gcc g++ libX11-dev libXt-dev libgl1-mesa-dev libosmesa6-dev libglu1-mesa-dev git cmake cmake-curses-gui libfontconfig-dev libxrender-dev make
  • libXt-devel (libXt-dev)
  • opengl/mesa (libgl1-mesa-dev and libosmesa6-dev)
  • glu (libglu1-mesa-dev)
  • libX11-devel (libX11-dev on Ubuntu 7.04)

Note: on a new machine you may need to run this before the line above:

sudo apt-get update

Debian squeeze

sudo apt-get install gcc libX11-dev libXt-dev libgl1-mesa-dev libosmesa6-dev libglu1-mesa-dev git cmake cmake-curses-gui libqt4-dev subversion make g++ libfontconfig-dev libxrender-dev
  • Debian squeeze has cmake 2.8.2 and Qt 4.6.3. You will need to install newer versions of these packages.

Debian testing (wheezy)

sudo apt-get install gcc libX11-dev libXt-dev libgl1-mesa-dev libosmesa6-dev libglu1-mesa-dev git cmake cmake-curses-gui libqt4-dev subversion make g++ libfontconfig-dev libxrender-dev

CentOS

  • CentOS user type:
yum install gcc-c++ libX11-devel libXt-devel make libXext-devel libGLU-devel mesa-libOSMesa-devel mesa-libGL-devel mesa-libGLU-devel ncurses

glx-utils provides glxgears that can be used to test rendering

Generic (need to confirm)

  • Logo CMake-PNG.png CMake >= 2.8.8
  • Git-logo.png Git >= 1.6.5
  • An easy way to get all of the packages needed to build Slicer is to install all of the packages needed to build paraview (another vtk-based program)
    • sudo apt-get install aptitude
    • sudo aptitude build-dep paraview
  • gcc
  • gcc-c++
  • libX11

Mac

  • Mac Os X >= 10.5 (Leopard)
  • Logo CMake-PNG.png CMake >= 2.8.8
  • Git-logo.png Git >= 1.6.5
  • XCode (for the SDK libs)
    • Newer Xcode versions (e.g. 4.3.2) use clang as the default compiler and clang is not compatible with ITK version 3. You should use ITK version 4 with recent versions of Xcode.
    • Xcode with gcc should work with either version of ITK.
    • OS X Mountain Lion: In Xcode 4.5 you now need to install command line tools (no longer included by default). Install within Xcode under the Xcode->Preferences->Downloads tab (otherwise git svn will give errors). Then you will need to install XQuartz (http://xquartz.macosforge.org) to get X11 (no longer a default in OS X).

Windows

  • Logo CMake-PNG.png CMake >= 2.8.8
  • Git-logo.png Git >= 1.6.5.
    • Git-1.7.9-preview20120201.exe recommended.
    • Use of TortoiseGit is optional.
    • Note For convenience, you could update the PATH variable so that git can be automatically discovered when configuring Slicer. If not, you will have to specify the GIT_EXECUTABLE at configure time.
  • SVN (e.g. SlikSvn or cygwin's svn client)
  • IDE
    • Tested/Recommended: Microsoft Visual Studio 9 2008 (Any edition).
      • Make sure to install:
        • SP1. Click here to download SP1 and click here to understand the motivation.
    • Experimental: The plan is to support Microsoft Visual Studio 2010 (Any edition). Note NOTE THAT EXPERIMENTAL MEANS THIS DOESN'T YET WORK :)
      • Make sure to install:
        • SP1. Click here to download SP1 and click here to understand the motivation.
        • SP1 Compiler update. Click here to download and here to understand the motivation.
    • Un-tested: Cygwin suite (building with cygwin gcc not supported, but the cygwin shell environment can be used to run git, svn, etc).
  • NSIS (optional): Needed if packaging Slicer - Click here to download.