Documentation/4.0/Developers/Build Instructions/Prerequisites

From Slicer Wiki
Jump to: navigation, search
Home < Documentation < 4.0 < Developers < Build Instructions < Prerequisites

For the latest Slicer developers documentation, visit the Nightly page.


Please check that the following tools are installed on your machine.

Required tools and libraries



Linux

Ubuntu

  • Ubuntu users, just type the following line in a terminal
sudo apt-get install subversion gcc g++ libX11-dev libXt-dev libgl1-mesa-dev libosmesa6-dev libglu1-mesa-dev git cmake cmake-curses-gui
  • libXt-devel (libXt-dev)
  • opengl/mesa (libgl1-mesa-dev and libosmesa6-dev)
  • glu (libglu1-mesa-dev)
  • libX11-devel (libX11-dev on Ubuntu 7.04)

Debian squeeze

sudo apt-get install gcc libX11-dev libXt-dev libgl1-mesa-dev libosmesa6-dev libglu1-mesa-dev git cmake cmake-curses-gui libqt4-dev subversion make g++
  • Debian squeeze has cmake 2.8.2 and Qt 4.6.3. You will need to install newer versions of these packages.

Debian testing (wheezy)

sudo apt-get install gcc libX11-dev libXt-dev libgl1-mesa-dev libosmesa6-dev libglu1-mesa-dev git cmake cmake-curses-gui libqt4-dev subversion make g++

CentOS

  • CentOS user type:
yum install gcc-c++ libX11-devel libXt-devel make libXext-devel

Generic (need to confirm)

  • Logo CMake-PNG.png CMake >= 2.8.4
  • Git-logo.png Git >= 1.6.5
  • An easy way to get all of the packages needed to build Slicer is to install all of the packages needed to build paraview (another vtk-based program)
    • sudo apt-get install aptitude
    • sudo aptitude build-dep paraview
  • gcc
  • gcc-c++
  • libX11

Mac

  • Mac Os X >= 10.5 (Leopard)
  • Logo CMake-PNG.png CMake >= 2.8.6
  • Git-logo.png Git >= 1.6.5
  • XCode (for the SDK libs)
  • XQuartz >= 2.7.2 for Mountain Lion

Windows

  • Logo CMake-PNG.png CMake >= 2.8.8
  • Git-logo.png Git >= 1.6.5.
    • Git-1.7.9-preview20120201.exe recommended.
    • Use of TortoiseGit is optional.
    • Note For convenience, you could update the PATH variable so that git can be automatically discovered when configuring Slicer. If not, you will have to specify the GIT_EXECUTABLE at configure time.
  • SVN (e.g. SlikSvn or cygwin's svn client)
  • IDE
    • Tested/Recommended: Microsoft Visual Studio 9 2008 (Any edition).
      • Make sure to install:
        • SP1. Click here to download SP1 and click here to understand the motivation.
    • Experimental: The plan is to support Microsoft Visual Studio 2010 (Any edition).
      • Make sure to install:
        • SP1. Click here to download SP1 and click here to understand the motivation.
        • SP1 Compiler update. Click here to download and here to understand the motivation.
    • Un-tested: Cygwin suite (building with cygwin gcc not supported, but the cygwin shell environment can be used to run git, svn, etc).