Difference between revisions of "Roadmap"

From Slicer Wiki
Jump to: navigation, search
 
(69 intermediate revisions by 4 users not shown)
Line 1: Line 1:
<div class="nonumtoc">__TOC__</div>
+
__NOTOC__
  
== Goals ==
+
The roadmap help organize and prioritize development activities based on input of Slicer community and the needs of funded projects (NA-MIC, NAC, NCIGT, SlicerRT, etc...)
This page is a place to organize and prioritize development activities into a roadmap based on input of Slicer community and the needs of funded projects (NA-MIC, NAC, NCIGT, SlicerRT, etc...)
 
  
The list of issues targeted for each release are reported on mantis: http://na-mic.org/Mantis/roadmap_page.php
+
The list of issues targeted for each release are listed on the issue tracker:
  
The topics listed below includes Slicer application and dependent ToolKit. For the specific strategy and feature lists covering modules and extensions, visit their respective roadmaps and other documentation.
+
{{documentation/banner
 +
| text  = https://issues.slicer.org/roadmap_page.php
 +
| background-color = FFFFFF }}
  
== Priorities ==
+
Discussions are found on the labs pages in the [[Documentation/Labs#Roadmap|roadmap]] section.
  
=== As of February, 2013 ===
+
<!--
 
+
For the specific strategy and feature lists covering modules and extensions, visit their respective roadmaps and other documentation.
* {{done}} [[Documentation/Labs/ITKv4|ITKv4 integration]]
+
-->
* {{wip}} Ability to install python package using pip
 
* {{done}} Improve extension catalog frontend
 
* {{wip}} Faster Slicer start time
 
* {{wip}} [http://www.na-mic.org/Bug/view.php?id=2039 Support of python command line module]
 
* {{done}} Walk-thru documentation that clearly shows new developers step-by-step instructions to create and publish extensions.
 
 
 
== Deprecation / API Changes roadmap ==
 
 
 
List of deprecated methods / classes: http://slicer.org/doc/html/deprecated.html
 
 
 
Mantis tag '''Deprecation''': http://www.na-mic.org/Bug/search.php?project_id=3&sticky_issues=on&sortby=last_updated&dir=DESC&hide_status_id=80&tag_string=Deprecation
 
 
 
 
 
=== Staged ===
 
 
 
This section list the change that should be annouced on the list before been integrated into Slicer trunk.
 
 
 
* Remove vtkMRMLScene::Edited method and associated SceneEditedEvent. See [http://www.na-mic.org/Bug/view.php?id=3472 #3472] and [https://github.com/jcfr/Slicer/tree/3472-remove-vtkMRMLScene-edited 3472-remove-vtkMRMLScene-edited]
 
* Rename qSlicer.*IO classes into qSlicer.*Reader. See [https://github.com/jcfr/Slicer/tree/rename-io-class-to-reader rename-io-class-to-reader]. See http://slicer-devel.65872.n3.nabble.com/Feedback-Rename-of-qSlicerXXXIO-class-into-qSlicerXXXReader-class-tt4030298.html
 
 
 
=== Trunk ===
 
* Library - ITKv3 support will be removed from build system.
 
* CMake -  Minimum required CMake version will be 2.8.11 for all platforms.
 
* MRML - Default value for HideFromEditors will be change to False. See [http://www.na-mic.org/Bug/view.php?id=2906 #2906].
 
* Wigdets - Method <code>currentNodeId</code> will be removed. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22059 22059].
 
* Clean logic header includes - [https://github.com/finetjul/Slicer/tree/vtkmrmlabstractlogic-clean-includes-trunk vtkmrmlabstractlogic-clean-includes-trunk].
 
* Cleanup qSlicerAppMainWindow - [https://github.com/finetjul/Slicer/tree/consolidate-qslicerappmainwindow-trunk consolidate-qslicerappmainwindow-trunk].
 
* Configure Qt modules - [https://github.com/finetjul/Slicer/tree/slicer-required-qt-modules-trunk slicer-required-qt-modules-trunk]
 
* Rename / Move - <code>vtkSlicerTransformLogic</code> will be renamed into <code>vtkSlicerTransformModuleLogic</code> and moved into <code>Modules/Loadable/Transform/Logic</code> - Consider updating the CMakeLists.txt and code of your modules. See instruction [[Documentation/Nightly/Developers/Tutorials/CreateLoadableModule#Dependency_between_modules|here]]. Associated issue [http://www.na-mic.org/Bug/view.php?id=2926 #2926]
 
* CMake - Rename file <code>SlicerMacroBuildQtModule.cmake</code> into <code>SlicerMacroBuildLoadableModule.cmake</code>. See issue [http://www.na-mic.org/Bug/view.php?id=3332 #3332]
 
 
 
=== 4.3.0 ===
 
* const std::vector<vtkMRMLDisplayNode*>& vtkMRMLDisplayableNode::GetDisplayNodes(); - Obsolete utility function that provides an unsafe API. Please use GetNumberOfDisplayNodes() and GetNthDisplayNode() instead
 
* CMake - Macro <code>slicerMacroBuildQtModule</code> will be renamed into <code>slicerMacroBuildLoadableModule</code>. See [http://www.na-mic.org/Bug/view.php?id=2648 #2648]
 
* CMake - Macro <code>slicerMacroBuildScriptedModule</code> should be used to build Scripted modules. See [https://github.com/xtk/SlicerWebGLExport/blob/0cd62734ad809bfc87aa422939c9732360d119df/WebGLExport/CMakeLists.txt#L32-36 here] for an example.
 
* Library - ITKv3 support is deprecated / not maintained.
 
* Scripted module should be built using <code>SlicerMacroBuildScriptedModule</code> instead of <code>ctkMacroCompilePythonScript</code>. See [https://github.com/Slicer/Slicer/commits/master/CMake/SlicerMacroBuildScriptedModule.cmake here].
 
* Generic tests associated with Loadable and Scripted module should be built specifying the <code>WITH_GENERIC_TESTS</code> option. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21768 r21768].
 
* Test driver associated with loadable module should be configured using <code>SlicerMacroConfigureModuleCxxTestDriver</code>. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21769 r21769].
 
* CMake - Minimum required CMake version will be 2.8.9 for Windows/Linux, CMake 2.8.11 for MacOSX - See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21682 r21682]
 
* Library - ITKv4 will be enabled by default - See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21688 r21688]
 
* Library - Qt 4.8.4 will be the recommended/required version
 
* Core - Removed unused class <code>Base/Logic/vtkSlicerROILogic</code> - See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21744 r21744]
 
* Move Editor icons from "Base/Logic" into "EditorLib/Resources/Icons". See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21765 r21765]
 
* CMake - Macro <code>slicer_parse_arguments</code> has been removed. Consider using <code>cmake_parse_arguments</code> instead. See [http://www.cmake.org/cmake/help/v2.8.10/cmake.html#module:CMakeParseArguments CMakeParseArguments] - See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21774 r21774]
 
* Slicer default Python version is <code>2.7.3</code> - See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21863 r21863], [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21867 r21867], [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21869 r21869], [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21879 r21879], [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21891 r21891]
 
* Python function PyRun_OpenFile/CloseFile have been removed. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21960 r21960]
 
* The <code>qMRMLNodeComboBox</code> property <code>currentNodeId</code> was renamed <code>currentNodeID</code>. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22052 22052]. The function <code>setCurrentNode(const QString &)</code> and <code>currentNodeId()</code> should be removed. See also [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22072 r22072].
 
* When using Visual Studio 8, installation of Service Pack 1 is now enforced by the build system. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22096 r22096], [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22098 r22098]
 
* <code>if(NOT Slicer_SOURCE_DIR)</code> not required any more in extension CMakeLists.txt. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22063 r22063]
 
* <code>project()</code> statment now allowed in extension CMakeLists.txt. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22038 r22038], [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22115 r22115]
 
==== SlicerExecutionModel ====
 
* CMake - CMake 2.8.4 will be required. Macro <code>Pre283CMakeParseArguments.cmake</code> will be removed. See [https://github.com/jcfr/SlicerExecutionModel/commit/ce6205807d7a8ce1b4c486a5507c94876636bec1 ce620580]
 
* CMake - Macro <code>slicerMacroBuildCLI</code> will be removed. Use <code>SEMMacroBuildCLI</code> instead.
 
* CMake - Parameter <code>CLI_SHARED_LIBRARY_WRAPPER_CXX</code> of macro <code>SEMMacroBuildCLI</code> is removed. Use <code>CLI_LIBRARY_WRAPPER_CXX</code> instead.
 
 
 
=== 4.2.0 ===
 
==== SlicerExecutionModel ====
 
* CMake - Macro <code>slicerMacroBuildCLI</code> marked as deprecated. See [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21634 r21634] and [http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=17781 r17781].
 
* CMake - Parameter <code>CLI_SHARED_LIBRARY_WRAPPER_CXX</code> of macro <code>slicerMacroBuildCLI / SEMMacroBuildCLI</code> is deprecated. Use <code>CLI_LIBRARY_WRAPPER_CXX</code> instead.
 

Latest revision as of 15:32, 11 December 2018

Home < Roadmap


The roadmap help organize and prioritize development activities based on input of Slicer community and the needs of funded projects (NA-MIC, NAC, NCIGT, SlicerRT, etc...)

The list of issues targeted for each release are listed on the issue tracker:

https://issues.slicer.org/roadmap_page.php

Discussions are found on the labs pages in the roadmap section.