Difference between revisions of "Documentation/Nightly/Developers/Build Instructions/Prerequisites/Qt5"

From SlicerWiki
Jump to: navigation, search
(Windows)
(Windows)
Line 10: Line 10:
 
File:Qt5_windows_install_3.png|3. Qt setup
 
File:Qt5_windows_install_3.png|3. Qt setup
 
File:Qt5_windows_install_4.png|4. Select installation folder  
 
File:Qt5_windows_install_4.png|4. Select installation folder  
File:Qt5_windows_install_5_1.png|5.1. Select Qt version 5.10.x or earlier for <tt>MSVC 2015 64-bit</tt> (5.11 and later would require VS2017 for Qt WebEngine component)
+
File:Qt5_windows_install_5_1.png|5.1. Select Qt version 5.10.x or earlier for <tt>MSVC 2015 64-bit</tt> (5.11 and later would require VS2017 for Qt WebEngine component). In recent Qt installer versions, you need to enable "LTS" package category and click "Refresh" button to see suitable Qt versions.
 
File:Qt5_windows_install_5_2.png|5.2. Select additional components <tt>Qt WebEngine</tt>, <tt>Qt Script</tt>
 
File:Qt5_windows_install_5_2.png|5.2. Select additional components <tt>Qt WebEngine</tt>, <tt>Qt Script</tt>
 
File:Qt5_windows_install_6.png|6. License
 
File:Qt5_windows_install_6.png|6. License

Revision as of 09:35, 9 May 2019

Home < Documentation < Nightly < Developers < Build Instructions < Prerequisites < Qt5

Windows

  1. Download qt-unified-windows-x86-online.exe
  2. Install Qt along with qtscript and qtwebengine components