Difference between revisions of "Documentation/Nightly/Developers/Build Instructions/Prerequisites"

From Slicer Wiki
Jump to: navigation, search
(→‎Windows: Fix Windows version)
Tag: 2017 source edit
(moved to readthedocs)
Tags: 2017 source edit, Replaced
Line 1: Line 1:
| text  = [https://slicer.readthedocs.io/en/latest/developer_guide/build_instructions/index.html This page has been moved to read-the-docs.]
| background-color = 8FBC8F }}
<!-- For all systems be sure git-lfs is properly installed for use with VTKv9 (required for VTKm checkout) -->
As of early 2018, Slicer migrated to Qt5. Qt4 support was removed in version 4.11. See instructions at this labs page for the new requirements: https://www.slicer.org/wiki/Documentation/Labs/Qt5-and-VTK8
Please check that the following tools are installed on your machine.
We try to keep current with the most recent releases of these prerequisites, but sometimes it's critical to use the exact versions specified here.  If you run into issues please do whatever you can to find a combination that works or contact the developer mailing list for suggestions.
| type = protection
| text = Qt libraries are '''required'''. Consider reading [[Documentation/{{documentation/version}}/Developers/Build_Instructions/Prerequisites/Qt|Qt requirements]].
| image= [[{{tool|logo|qt}}|x40px]]
| type = protection
| text = CMake is '''required'''.
| image= [[{{tool|logo|cmake}}|x40px]]
| type = protection
| text = &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Git is '''required'''.
| image= [[{{tool|logo|git}}|x40px]]
| type = protection
| text = SVN is '''required'''.
| image= [[{{tool|logo|svn}}|x40px]]
The prerequisites listed below are required to be able to configure/build/package/test Slicer.
*[{{tool|download|cmake}} CMake] >= 3.13.4
*[{{tool|download|git}} Git] >= 1.7.10
*[{{tool|download|svn}} Svn] >= 1.7
*Qt 5.11: <b>tested and recommended</b>
**To build Slicer: install Qt using the distribution package manager.
**To package and redistribute Slicer: download and execute [https://download.qt.io/official_releases/online_installers/qt-unified-linux-x64-online.run qt-unified-linux-x64-online.run], install Qt, make sure to select <tt>qtscript</tt> and <tt>qtwebengine</tt> components.
*GCC suite
*Debian squeeze/wheezy/testing(jessie) users, start by pasting the following lines in a terminal
  sudo apt-get install subversion git-core git-svn
sudo apt-get install build-essential libx11-dev libxt-dev libgl1-mesa-dev libosmesa6-dev libglu1-mesa-dev libfontconfig-dev libxrender-dev libncurses5-dev
sudo apt-get install cmake
sudo apt-get install qt-sdk
<hr />
=====Common Prerequisites=====
sudo apt-get install subversion git-core git-svn
sudo apt-get install make gcc g++ libx11-dev libxt-dev libgl1-mesa-dev libglu1-mesa-dev libfontconfig-dev libxrender-dev libncurses5-dev libxkbcommon-x11-0
sudo apt-get install libosmesa6-dev  # Only for Ubuntu < 14.04.3
{{remark|red|On Ubuntu 14.04.3 LTS, attempting to install <tt>libosmesa6-dev</tt> results in an error.<pre>
The following packages have unmet dependencies:
libosmesa6-dev : Depends: libosmesa6 (= 10.1.3-0ubuntu0.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
For more details, see [https://bugs.launchpad.net/ubuntu/+source/mesa-lts-utopic/+bug/1424059 Bug 1424059].}}
{{remark|green|Slicer compiles successfully without that package, but <tt>VTK_OPENGL_HAS_OSMESA</tt> is disabled.}}
*For Qt5.5 on Ubuntu 16.04
sudo apt-get install libgstreamer-plugins-base0.10-dev
<li>Open a terminal and copy the command reported below</li>
<li>Download stable version of CMake and extract the archive:
sudo apt-get install curl
mkdir ~/Support && cd ~/Support
curl -O https://cmake.org/files/v3.13/cmake-3.13.4-Linux-x86_64.tar.gz
tar -xzvf cmake-3.13.4-Linux-x86_64.tar.gz
<li>Create symbolic links into <code>~/bin</code>
mkdir -p ~/bin
for name in cmake ctest cpack ccmake cmake-gui; do
  ln -s ~/Support/cmake-3.13.4-Linux-x86_64/bin/$name ~/bin/$name
{{remark|red|You <b>MUST</b> download the standard CMake binary because the distributed version of CMake cannot be used to build slicer.<br>
See [[Documentation/{{documentation/version}}/Developers/FAQ/Building#Why_distributed_CMake_can_not_be_used_on_Ubuntu_12.04_and_above_.3F|here]] for more details.}}
See instructions reported in [https://github.com/Slicer/SlicerBuildEnvironment/blob/master/Docker/qt5-centos7/Dockerfile qt5-centos7/Dockerfile]
*CentOS user type:
yum install make gcc-c++ libX11-devel libXt-devel libXrender-devel libXext-devel libGLU-devel mesa-libOSMesa-devel mesa-libGL-devel mesa-libGLU-devel ncurses
Todo: This will have to be added in FAQ: Troubleshoot section
''glx-utils'' provides ''glxgears'' that can be used to test rendering
*XCode command line tools must be installed:
  xcode-select --install
*El Capitan is what most developers use.
*CMake 3.12.2 is recommended. Check the minimum required CMake version [https://github.com/Slicer/Slicer/blob/master/CMakeLists.txt#L1 here]
*Large File Storage for git is required. (<tt>brew install git-lvs)</tt>
*Qt 5: <b>tested and recommended</b>.
**For building Slicer: download and execute [https://download.qt.io/official_releases/online_installers/qt-unified-mac-x64-online.dmg qt-unified-mac-x64-online.dmg], install Qt 5.10, make sure to select <tt>qtscript</tt> and <tt>qtwebengine</tt> components.
**For packaging and redistributing Slicer: build Qt using [https://github.com/jcfr/qt-easy-build#readme qt-easy-build]
*Setting <tt>CMAKE_OSX_DEPLOYMENT_TARGET</tt> CMake variable specifies the minimum macOS version a generated installer may target.  So it should be equal to or less than the version of SDK you are building on. Note that the SDK version is set using <tt>CMAKE_OSX_SYSROOT</tt> CMake variable automatically initialized during CMake configuration.
====MacOSX 10.9.4 (Mavericks)====
''' (1) Make sure to install this update: http://support.apple.com/kb/DL1754'''
''' (2) Use CMake 3.12.2 - it is known to be working and is supported''' (if you want to use CMake already installed on your system, is known to work on Mac OS X 10.9.5)
*Mac Os X >= 10.5 (Leopard)
*[{{tool|download|cmake}} CMake] >= 2.8.9
**For Mac Os X >= 10.8 ([http://en.wikipedia.org/wiki/OS_X_Mountain_Lion Mountain Lion]) and/or recent XCode >= 4.5.X - [{{tool|download|cmake}} CMake] >= 2.8.11 is required. See http://www.cmake.org/files/v2.8/cmake-2.8.11-Darwin64-universal.tar.gz
<!-- Waiting for the official release, get the release candidate rc1 [http://www.cmake.org/files/v2.8/cmake-2.8.11-rc1-Darwin64-universal.tar.gz here]. For explanation, see [[Documentation/{{documentation/version}}/Developers/Build_Instructions#ld:_framework_not_found_QtWebKit|here]] and [[Documentation/{{documentation/version}}/Developers/Build_Instructions#On_MacOSX_10.8.2C_CMake_hangs_forever|here]]. These versions are also known to work: exact version 20130121-g92bd8 [http://www.cmake.org/files/dev/cmake- here] (or version >= [http://www.cmake.org/files/dev/?C=M;O=D here]).
$ curl -O http://www.cmake.org/files/v2.8/cmake-2.8.11-Darwin64-universal.tar.gz
$ tar -xzvf cmake-2.8.11-Darwin64-universal.tar.gz --strip-components=1
$ CMake\ 2.8-11.app/Contents/bin/cmake --version
cmake version 2.8.11
*[{{tool|download|git}} Git] >= 1.7.10
*[{{tool|download|svn}} Svn] >= 1.7
*[[{{tool|logo|cmake}}|x16px]] [{{tool|download|cmake}} CMake] >= 2.8.9
*[[{{tool|logo|git}}|x16px]] [{{tool|download|git}} Git] >= 1.6.5
*XCode (for the SDK libs)
**After installing XCode, install XCode command line developer tools:
xcode-select --install
*XQuartz - For Mac Os X >= 10.8 ([http://en.wikipedia.org/wiki/OS_X_Mountain_Lion Mountain Lion]) install XQuartz (http://xquartz.macosforge.org) to get X11 (no longer a default in OS X).
*Qt 4 >= 4.8.5. We recommend you install the following two packages:
**Download and install [http://download.qt-project.org/official_releases/qt/4.8/4.8.6/qt-opensource-mac-4.8.6-1.dmg qt-opensource-mac-4.8.6-1.dmg]
**Download and install [http://download.qt-project.org/official_releases/qt/4.8/4.8.6/qt-opensource-mac-4.8.6-1-debug-libs.dmg qt-opensource-mac-4.8.6-1-debug-libs.dmg]
**For more details [[Documentation/{{documentation/version}}/Developers/Build_Instructions/Prerequisites/Qt#Mac|here]]
** Newer Xcode versions (e.g. 4.3.2) use clang as the default compiler and '''clang is not compatible with ITK version 3'''.  You should use ITK version 4 with recent versions of Xcode.
** Xcode with gcc should ork with either version of ITK.
** OS X Mountain Lion: In Xcode 4.5 you now need to install command line tools (no longer included by default). Install within Xcode under the Xcode->Preferences->Downloads tab (otherwise git svn will give errors). Then you will need to install XQuartz (http://xquartz.macosforge.org) to get X11 (no longer a default in OS X).
====Mac OSX 10.11 (El Capitan)====
XCode up to version 7 is known to work for Slicer compilation. XCode 8 breaks things on several levels for now.
Remember to install XCode command line tools (see above) if a reinstall for XCode is needed.
The standard Qt4 installers fail on this version and the 4.8.6 source code won't build.  But [http://slicer-devel.65872.n3.nabble.com/incompatible-qt-4-8-6-with-OS-X-El-Capitan-td4035551.html as described on the slicer-devel mailing list] it is possible to install the [https://github.com/Homebrew/formula-patches/blob/master/qt/el-capitan.patch homebrew version of qt4 which patches it to work on El Capitan] (see below).
*Install the '''OS''', '''Xcode''', and '''XQuartz''' (see MacOSX 10.10 above)
*Install '''Qt4''' by running the following two commands:
brew install qt4
xcode-select --install
*TCL does not build correctly on El Capitan as of 2015-12-03, so when building Slicer turn `Slicer_USE_PYTHONQT_WITH_TCL` off.
====Mac OSX 10.12 (Sierra)====
Similar to 10.11 (El Capitan), there are new issues with Qt4 (caused by Phonon).
The GitHub user Cartr [https://github.com/Homebrew/homebrew-core/pull/5216 offered a patch to the brew team], and even though it was not integrated (the homebrew team decided to stop patching their recipe to encourage people to use Qt5), he [https://github.com/cartr/homebrew-qt4 turned his formula into a tap] that can be installed (see below).
Follow instructions for 10.11 ''(Installing Xcode, XQuartz, run without TCL)'' but install '''Qt4''' like shown below instead:
brew install cartr/qt4/qt
xcode-select --install
Confirmed with Xcode:
*Version 8.1 (8B62) and cmake version 3.4.20151021-g8fbc8e
*Version 8.3.3 and cmake 3.5.2
make -j `sysctl -n hw.ncpu`
====Mac OSX 10.14 (Mojave)====
<small>Associated discussion topic is https://discourse.slicer.org/t/building-on-mac-10-14-mojave/4554/21</small>
*Install Qt 5.11.2 using [http://download.qt.io/official_releases/online_installers/qt-unified-mac-x64-online.dmg Qt Online Installer for macOS]
*Install XCode:
xcode-select --install
*Build qt from homebrew
brew install qt
ccmake -DCMAKE_OSX_DEPLOYMENT_TARGET=10.14 -DQt5_DIR=/usr/local//Cellar/qt/5.13.2/lib/cmake/Qt5 ~/slicer/latest/Slicer
*Explicitly set the SDK when running make
SDKROOT=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk make -j20
Note if you have build errors in dcmtk related to iconv symbols, you may need to uninstall the icu4c and dcmtk homebrew packages during the build process.  See [https://github.com/QIICR/dcmqi/issues/395 here] and [https://github.com/Slicer/Slicer/commit/6523a62d776e64f970c554978a3c3a8f26022db5 here].
====Common Prerequisites====
*[{{tool|download|cmake}} CMake] >= 3.15.1
*[{{tool|download|git}} Git] >= 1.7.10
*[[{{tool|logo|cmake}}|x16px]]  [{{tool|download|cmake}}  CMake] >= 3.13.4
*[[{{tool|logo|git}}|x16px]]  [{{tool|download|git}}  Git] >= 1.7.10
* [https://code.google.com/p/msysgit/downloads/list?can=3 ''Git-X.X.X-preview2013XXXX.exe''] recommended.
** Use of [http://code.google.com/p/tortoisegit/ TortoiseGit] is optional.
**{{note}}CMake must be able to find ''git.exe'' and ''patch.exe''. If git is installed in the default location then they may be found there, but if they are not found then either add the folder that contains them to PATH environment variable; or set GIT_EXECUTABLE and Patch_EXECUTABLE as environment variables or as CMake variables at configure time.
*Subversion (SVN) client: any SVN client that has command line tools
**[http://www.sliksvn.com/en/download SlikSvn] <!-- or [http://www.cygwin.com cygwin's svn client]-->, or
**[https://tortoisesvn.net/downloads.html TortoiseSVN] - make sure you install ''Command line client tools'' component (disabled by default)
*NSIS (optional): Needed if packaging Slicer - Click [http://nsis.sourceforge.net/Download here] to download. Make sure you install the language packs.
*Qt5: Download download Qt universal installer from [https://www.qt.io/download-open-source here] and install Qt 5.15 along with <tt>qtscript</tt> and <tt>qtwebengine</tt> components. For examples of the installation procedure, see this [[Documentation/Nightly/Developers/Build Instructions/Prerequisites/Qt5|step-by-step]] guide.
====Tested and recommended build environment====
*VS2017 (Visual Studio 15 2017 Win64)
*VS2019 (Visual Studio 16 2019 Win64)
*Older VS toolsets can be used with newer IDES
**When configuring Visual Studio installer, enable installation of Visual Studio 2017 (v141) or Visual Studio 2015 (v140) toolsets
**For older toolsets,  must be set in CMake: ''Optional toolset to use (argument to -T)'' need to be set to ''v141'' or ''v140''
**Make sure you enable installation of component ''Programming languages / Visual C++ / Common Tools for Visual C++'' (in some distributions, this option is not enabled by default)
*Qt 5.15
*CMake >= 3.15.1
====Experimental/deprecated build environments====
*VS2015 (Visual Studio 14 2015 Win64) Update 3
**Requires Qt 5.10.x to build due to QtWebEngine.  For more details, read this [[Documentation/Nightly/Developers/Build Instructions/Prerequisites/Qt5|step-by-step]] guide to download and install.
*Cygwin (untested, probably does not work)
**Cygwin suite (building with cygwin gcc not supported, but the cygwin shell environment can be used to run git, svn, etc).

Latest revision as of 19:04, 6 August 2020

Home < Documentation < Nightly < Developers < Build Instructions < Prerequisites