Difference between revisions of "Documentation/Nightly/Developers/Build Instructions/Prerequisites"

From Slicer Wiki
Jump to: navigation, search
Line 64: Line 64:
  
 
'''For Ubuntu < 14.04.3''':
 
'''For Ubuntu < 14.04.3''':
  sudo apt-get libosmesa6-dev
+
  sudo apt-get install libosmesa6-dev
  
 
* NOTE: on Ubuntu 14.04.3 LTS, attempting to install <tt>libosmesa6-dev</tt> results in an error:
 
* NOTE: on Ubuntu 14.04.3 LTS, attempting to install <tt>libosmesa6-dev</tt> results in an error:

Revision as of 21:44, 1 October 2015

Home < Documentation < Nightly < Developers < Build Instructions < Prerequisites


PREREQUISITES


Consider reading platform specific requirements listed below.

Linux

  • CMake >= 3.x
  • Git >= 1.7.10
  • Svn >= 1.7
  • Qt 4.8.6. See details here (Note that any version >= Qt 4.7.4 can be used only for Ubuntu < 12.04)

Debian

  • Debian squeeze/wheezy/testing(jessie) users, start by pasting the following lines in a terminal
sudo apt-get install subversion git-core git-svn
sudo apt-get install make gcc g++ libX11-dev libXt-dev libgl1-mesa-dev libosmesa6-dev libglu1-mesa-dev libfontconfig-dev libxrender-dev libncurses5-dev
sudo apt-get install cmake
sudo apt-get install qt-sdk

Ubuntu

  • Ubuntu users, start by pasting the following lines in a terminal
sudo apt-get install subversion git-core git-svn
sudo apt-get install make gcc g++ libX11-dev libXt-dev libgl1-mesa-dev libglu1-mesa-dev libfontconfig-dev libxrender-dev libncurses5-dev


For Ubuntu < 12.04:

sudo apt-get install cmake # Only for Ubuntu < 12.04

For Ubuntu < 14.04.3:

sudo apt-get install libosmesa6-dev
  • NOTE: on Ubuntu 14.04.3 LTS, attempting to install libosmesa6-dev results in an error:
The following packages have unmet dependencies:
 libosmesa6-dev : Depends: libosmesa6 (= 10.1.3-0ubuntu0.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

See Bug 1424059.

Slicer compiles successfully without that package, but VTK_OPENGL_HAS_OSMESA is disabled.

For Ubuntu 12.04 and above: You *MUST download the standard CMake binary* from http://cmake.org/download because the distributed version of CMake cannot be used to build slicer. For example, on a 64-bit system, you will download the file cmake-X.Y.Z-Linux-x86_64.tar.gz associated with the latest stable version.

References:


For Ubuntu 12.04, 12.10, 13.04 and 13.10: Qt 4 >= 4.8.5 MUST be used. See reference below for more details.

cd ~/Support   # This is where we will build Qt and dependent libraries
 
# Keep track of our working directory
cwd=$(pwd)

# This will download, then build zlib and openssl in the current folder
rm -f get-and-build-openssl-for-slicer.sh
wget https://gist.githubusercontent.com/jcfr/9513568/raw/21f4e4cabca5ad03435ecc17ab546dab5e2c1a2f/get-and-build-openssl-for-slicer.sh
chmod u+x get-and-build-openssl-for-slicer.sh 
./get-and-build-openssl-for-slicer.sh 

# This will download Qt source in the current folder
wget http://packages.kitware.com/download/item/6175/qt-everywhere-opensource-src-4.8.6.tar.gz
md5=`md5sum ./qt-everywhere-opensource-src-4.8.6.tar.gz | awk '{ print $1 }'` &&
[ $md5 == "2edbe4d6c2eff33ef91732602f3518eb" ] || echo "MD5 mismatch. Problem downloading Qt"

# This will configure and build Qt in RELEASE against the zlib and openssl previously built
tar -xzvf qt-everywhere-opensource-src-4.8.6.tar.gz
mv qt-everywhere-opensource-src-4.8.6 qt-everywhere-opensource-release-src-4.8.6
mkdir qt-everywhere-opensource-release-build-4.8.6
cd qt-everywhere-opensource-release-src-4.8.6
./configure -prefix $cwd/qt-everywhere-opensource-release-build-4.8.6/    \
                   -release \
                   -opensource -confirm-license \
                   -no-qt3support \
                   -webkit \
                   -nomake examples -nomake demos \
                   -openssl -I $cwd/openssl-1.0.1e/include   -L $cwd/openssl-1.0.1e \
&& make -j7 && make install

References:

  • Why Qt 4 >= 4.8.5 should be used on Ubuntu 12.04 and above ?

CentOS

  • CentOS user type:
yum install make gcc-c++ libX11-devel libXt-devel libXext-devel libGLU-devel mesa-libOSMesa-devel mesa-libGL-devel mesa-libGLU-devel ncurses


MacOSX

MacOSX 10.9.4 (Maverick):

(1) Make sure to install this update: http://support.apple.com/kb/DL1754

(2) Use CMake 3.0.1 - it is known to be working and is supported (if you want to use CMake already installed on your system, 2.8.12.2 is known to work on Mac OS X 10.9.5)

$ curl -O http://www.cmake.org/files/v2.8/cmake-2.8.11-Darwin64-universal.tar.gz
$ tar -xzvf cmake-2.8.11-Darwin64-universal.tar.gz --strip-components=1
$ CMake\ 2.8-11.app/Contents/bin/cmake --version
cmake version 2.8.11

Windows

  • CMake >= 3.0
  • Git >= 1.7.10
    • Note For convenience, you could update the PATH variable so that git can be automatically discovered when configuring Slicer. If not, you will have to specify the GIT_EXECUTABLE at configure time.
  • SlikSvn . If using TortoiseSVN (versions that support command line tools), make sure you install Command line tools (disabled by default)
  • NSIS (optional): Needed if packaging Slicer - Click here to download.
  • Qt 4.8.6 (for VS2008). See details here
    • Normally you should plan to build Qt from source to have complete control over the process. See one-liner build command
    • You may find that the unsigned binary downloads from this site are usable: http://sourceforge.net/projects/qt64ng/files/qt/x86-64/4.8.6/msvc2008/ (If you use .7z varaints extract them in the default location C:\Qt\ otherwise that installation will not be properly configured for use with CMake)
    • Details: Using the Qt Designer on Windows requires that the Slicer plugins are compiled in the same mode as Qt. If Qt was compiled in Release mode (default), Slicer would have to be compiled in Release mode as well. However if Qt is compiled in Debug mode only, Slicer has to be compiled in Debug too. When Qt is in "Release and Debug" mode only the Release version of Designer.exe is generated, Slicer would have to be compiled in Release. So for developers, the Debug mode is recommended.
    • For VS2012 Qt needs to be build from source. Build will fail, which can be fixed with this diff: https://gist.github.com/Vitallium/5220503 (read the comment too)
  • IDE
    • Tested/Recommended: Microsoft Visual Studio 9 2008 (Any edition). VS Express 2008 with SP1 direct link (functional as of Jan 11, 2014)
    • Experimental: The plan is to support Microsoft Visual Studio 2010 (Any edition). Note NOTE THAT EXPERIMENTAL MEANS THIS DOESN'T YET WORK :)
      • Make sure to build or install:
        • Qt 4.8
      • Make sure to install:
        • SP1. Click here to download SP1 and click here to understand the motivation.
        • SP1 Compiler update. Click here to download and here to understand the motivation.
    • Experimental (Visual Studio 2012): Use a desktop version such as Visual Studio 2012 Express for Windows Desktop and remember Visual Studio 2012 Update 2). Do not use Visual Studio Express 2012 for Windows 8. You must install Windows SDK, otherwise CMake will not even find the C compiler during configure. In CMake, choose Visual Studio 11 Win64 as generator.
    • Experimental (Visual Studio 2013 with Update 5, as of commit e5eb478): Slicer compilation is successful, with some caveats. Steps:
      • CMake >= 3.3.1
      • Build Qt 4.8.7 with SSL support using qt-easy-build.
      • For Debug mode, disable Slicer_USE_NUMPY and Slicer_USE_SimpleITK in CMake.
      • For Release mode, disable Slicer_USE_NUMPY in CMake.
    • Un-tested: Cygwin suite (building with cygwin gcc not supported, but the cygwin shell environment can be used to run git, svn, etc).