Introduction

- Welcome to 3D Slicer!
Overview of Training

- What is Slicer?
- Uses of Slicer
- Getting Slicer
- How to Use Slicer
  - Loading Data
  - Viewing Data
  - Modifying Data
  - Saving Data
What is Slicer?
Slicer

- Slicer is:
  - freely available, open-source software
  - for visualizing
    registering
    segmenting
    modeling
    quantifying
    medical image data
Slicer Structure

- Modular
  - Many existing modules.
  - Can develop own modules.
- Languages
  - Tcl / C++
  - Tk
  - VTK
Slicer Development

- an ongoing collaboration between:
  - MIT Artificial Intelligence Lab
  - Surgical Planning Lab (SPL)
    - Part of Brigham & Women's Hospital (BWH)
    - An affiliate of Harvard Medical School
- Developers can share modules.
Acknowledgements

- Biomedical Informatics Research Network (BIRN)
- Brigham and Women's Hospital (BWH)
- Harvard Medical School
- Johns Hopkins University
- Massachusetts Institute of Technology (MIT)
- National Center for Research Resources (NCRC)
- National Science Foundation (NSF)
Disclaimer

• 3D Slicer is NOT for clinical use.
• The 3D Slicer software, and the contents of the 3D Slicer documentation, are intended for educational, research, and informational purposes only.
• 3D Slicer, or information derived from 3D Slicer, may be used only for research and may not under any circumstances whatsoever be used for clinical purposes.
• The 3D Slicer software is not intended for treating or diagnosing human subjects, and the recipient and user will not use the 3D Slicer software for those purposes.
• The 3D Slicer copyright holders and contributors, Brigham and Women's Hospital, and all affiliated organizations assume no responsibility for the use of 3D Slicer for unintended purposes.
Uses of Slicer
Some Uses of Slicer

- Image-guided medicine
- Viewing image data: 2D and 3D
- Image analysis
  - Registration (aligning data sets)
  - Segmentation (extracting 3D structures)
  - Generating 3D surface models
  - Quantitative analysis:
    • distances, angles, surface areas, and volumes
Users

• A variety of users and organizations employ Slicer for many tasks.
Medical Research

- Visualizing anatomical structures
- Comparative studies
- Quantitative measurements
- Generating figures for publication
Diagnostic Research

• Viewing anatomical structures
• Comparing images from different sources
• Changes over time
• Post-operative differences
Surgical Planning

- Viewing anatomical structures
- 3D models
- Stages of procedures
Intra-operative Imaging

- Integrated Slicer with an open MR scanner
- Full array of pre-operative data
- Exploring anatomical changes during surgery
- Tracks surgical instruments
- Applied in dozens of neurosurgical cases at BWH
- Routinely used for 1-2 research cases per week.
Getting Slicer
Platforms

• Slicer is available on a variety of popular medium- to high-end platforms
• Any modern PC or workstation with a graphics chip should work fine
Solaris (1 of 2)

- Sun UltraSPARC workstations running:
  - Sun Solaris 2.8 (also known as Solaris 8 or SunOS 5.8)
  - OpenGL 1.2
Solaris (2 of 2)

• Hardware:
  – Memory: 128 MB+
  – Disk Space: 35.6 MB for installer, which expands to 145 MB
    + 37 MB for tutorial data set
  – Processor Speed: 450 MHz +
Windows (1 of 2)

- PCs running:
  - Windows 98
  - Windows NT / 2000 / XP
Windows (2 of 2)

• Hardware
  – Memory: 128 MB +
  – Disk Space: 11.5 MB for installer, which expands to 45 MB
    + 37 MB for tutorial data set
  – Processor Speed: 333 MHz +
  – Screen Resolution: 1024 x 786 +
    1280 x 1024 suggested
  – Colors: 16 bit color +
Linux

- Red Hat Linux 7.3
- Hardware:
  - Memory: 128 MB+
  - Disk Space: 31.6 MB for installer, which expands to 119 MB
    + 37 MB for tutorial data set
  - Processor Speed: 450 MHz +
Mac OS X

- Apple Macintosh computers running:
  - Mac OS 10.2
  - X Windows Server
- Hardware
  - Recent Vintage Computer
    - We are working on exact requirements.
Other Platforms

- Source code is freely available.
- Users can compile it for their operating system.
Getting Slicer

- For research only
- Download slicer2 and install
- Includes documentation
- Sample data available
Running Slicer

• Run the executable for your platform.
• On platforms other than Windows, Linux, Solaris, or Mac OS X, you will need to compile Slicer source code before running.
• Contact the developer list for help.
Support

• User’s mailing list:
  – slicer-users-request@lists.bwh.harvard.edu
• Developer’s mailing list:
  – slicer-devel-request@lists.bwh.harvard.edu
• slicer@ai.mit.edu
How to Use Slicer

- Slicer interface
- Loading data
- Viewing data
- Modifying data
- Saving data
Slicer Interface

- Graphical User Interface
  - The **Menu** window
  - Buttons, menus, sliders, input boxes
  - Panels, tabs
  - Graphical viewer
Submenus

- **File**
  - Opening files
  - Saving files
  - Close
  - Exit

- **View**
  - Selecting view mode

- **Help**
  - Links to Slicer information
Main menu

- Group of buttons
  - Data
  - Volumes
  - Models
  - Alignments
  - Editor
  - ModelMaker
Panels and Tabs

- Clicking a **Main** menu button opens a panel.
- Each panel has tabs along the top.
- Leftmost tab is **Help**.
- Panel may contain controls and displays.
Viewer window

- Upper part is **3D Viewer**
- Lower part is **2D Viewer**
  - 3 separate views
  - Independent controls
Modules

- Slicer is modular.
- Some sample modules:
  - **View**: customizes size of viewer window.
  - **Anno**: controls annotation displayed.
  - **Slices**: selects slices to display in 3D.
  - **Colors**: creates color palette.
  - **Measure**: calculates Surface Area, Volume, and Cross Sectional Area.
  - **MeasureVol**: measures volume of segmented structures in a label map.
Exercise: Slicer GUI

- Launch Slicer.
  - Observe **Main** window and **Viewer** window.
- Click **File, View, Help, and Modules**.
  - Examine submenus.
- Click **Main Menu** buttons: **Data, Volumes, Models, Alignments, Editor, and ModelMaker**.
  - Click tabs.
  - Examine panels.
- Click **More**.
  - Click modules: click tabs, examine panels.
Loading Data

• Slicer can:
  – Load volumes of image data
  – Load models
  – Load saved scenes
Loading Volumes

- Volume: a collection of volume elements (voxels) of an image.
  - Example: A slice is an example of a volume.
- Slicer reads many medical image types:
  - GE Signa
  - GE Genesis
  - DICOM (digital imaging and communications in medicine)
  - Non-header images
- General procedure:
  - **Main → Data → Add Volume**
Volumes with Headers (1 of 2)

- **Main → Data**
  - **Data** panel appears.

- Click **Add Volume**.
  - **Props** (Properties) tab of **Volumes** panel appears.

- To find first image, click **Browse**.
  - A dialog box appears.

- Select first image of volume to load, and click **Open**.
  - The number of the last image in the volume automatically appears in the **Number of Last Image** field.
Volumes with Headers (2 of 2)

- Leave **Image Headers** on **Auto**.
- **Image Data** buttons: select whether images are grayscale or label maps.
  - Label map: the output of a segmentation.
- **Name** field: the name that volume will have within Slicer.
  - Change to something descriptive: “Cortex“.
- **Description** field: You may enter a description.
- Click **Apply** to read in the volume.
  - Your data appears in the 2D portion of the **Viewer** window.
Exercise: Volume with Header

- **Main → Data: Data** panel appears.
- Click **Add Volume: Props** tab appears.
- Click **Browse: Tutorial → spgr**
  - Click **Ⅰ.001** and click **Open**.
  - **Number of Last Image** appears.
- Click **Apply**.
  - Images appear in bottom of **Viewer**.
- Click **Main → Data → List**.
  - Volume **Ⅰ** is in list
Volumes without Headers (1 of 4)

- Similar to “with headers”, but needs more manual input.
- **Main → Data**
  - Data panel appears.
- Click **Add Volume**.
  - Props (Properties) tab of Volumes panel appears.
- To find first image file, click **Browse**.
  - A dialog box appears.
- Select first image of volume to load, and click **Open**.
  - The number of the last image in the volume automatically appears in the Number of Last Image field.
Volumes without Headers (2 of 4)

- Set **Image Headers** to **Manual**.
- Click **Apply**.
  - The **Header** section of the **Props** tab appears.
- Change default values for volume.
  - **File Pattern**: Pattern of file names, in C syntax. Example: a file named `skin.001` has a pattern of `%s.%03d`.
  - **Image Size**: Number of pixels of image in x and y directions.
• More default values to change.
  – **Pixel Size**: Size of each pixel in the x and y directions. (For square images, they are equal.)
  – **Slice Thickness**: The z dimension of the voxel.
  – **Scan Order**:  
    • **LR** = left to right  
    • **IS** = inferior to superior  
    • **PA** = posterior to anterior
  – **Scalar Type**: Data format of the pixel. Generally, it is Short (16 bit integer).
  – **Slice Tilt**: The tilt of the gantry during an MRI.
Volumes without Headers (4 of 4)

• Still more default values to change.
  – **Num Scalars**: Number of scalar components for each voxel. Gray-scale data: 1. Color data: 3.
  – **Little Endian**: In little-endian architectures, the rightmost bytes are most significant. In big-endian architectures (Slicer default), the leftmost bytes (those with a lower address) are most significant.
  – **DTI data, Swap, No Swap**: Placeholders for future.
• Click **Apply** to read in the volume.
  – Your data appears in the 2D Viewer window.
Exercise: Volume w/out Header

- **Main → Data: Data** panel appears.
- Click **Add Volume: Props** tab appears.
- Click **Browse: Tutorial → labels**
  - Click all.001 and click **Open**.
  - **Number of Last Image** appears.
- Click **Apply**.
  - “No header information found”: click **OK**.
  - Examine default data values.
- Click **Apply**.
- **Volume all** appears in **Data → List**.
Loading DICOM Volumes (1 of 4)

- Digital Imaging and COmmunications in Medicine
- Slicer reads most, not all, the many DICOM flavors.
- From **Main** menu, click **Data**. The **Data** panel appears.
- Click **Add Volume**. The **Props** panel appears.
- From **Properties** pull-down menu, select **Dicom**.
- Click **Select DICOM Volume**.
  - A dialog box appears.
- Select directory and click **OK**.
  - Slicer searches for every DICOM file.
  - A dialog box appears showing patient, studies, series, and files.
Loading DICOM Volumes (2 of 4)

- Select or deselect images to load.
  - Selected images are green; deselected images are red.
- **Increasing** or **Decreasing**: loads images in either order.
- **Preview**: displays small icon-size images in bottom panel.
  - The default size is 32x32 pixels.
  - You can change the size of the previewed images.
- **List Headers**: displays header information about image.
- **Check**: displays information about how to group the data.
  - Helps to show when slices are missing.
  - Also useful when several DICOM acquisitions are lumped together.
Loading DICOM Volumes (3 of 4)

- Select a patient, a study of this patient, a series of this study, and the files of this series. Then click **OK**.
  - The header data of the first file will be extracted. (You may select additional files.)
- To show header information, click **Extract Header**.
- To check and modify the extracted values, click **Header**.
- On **Basic** panel, use **Image Data** buttons to select whether images are grayscale or label maps.
Loading DICOM Volumes (4 of 4)

• **Name** field: the name that volume will have within Slicer.
  – Change to something descriptive: “Cortex“.

• **Description** field: You may enter a description.

• Click **Apply** to save **Name** and **Description**.

• Click **Apply** to read in the volume.
  – Your data appears in the 2D portion of the **Viewer** window.
Loading Models

- A model is a 3D surface.
- **Main → Data**
- Click **Add Model**.
  - **Props** tab appears.
- Click **Browse**.
- In dialog box, select the model to load (VTK PolyData format), and click **Open**.
- **Name** field: name within Slicer.
  - Make descriptive: “Cortex“.
- From **Color** pull-down menu, select color for the **3D Viewer**.
- Click **Apply** to read in the model.
Exercise: Loading Model

- **Main → Data → Add Model.**
  - **Props** tab appears.
- **Click Browse: Tutorial → models**
- **Click model file (.vtk) and click Open.**
- **Click Color** and select color for model.
- **Click Apply** to read in the model.
Opening a Saved Scene

• Click **File**.
• Click **Open Scene**.
• Find the scene `.xml` file.
• Double-click file.
• Wait for the volumes and models to load.
Viewing Data

- Slicer offers many ways to view 2D and 3D data.
  - A single series of grayscale images
  - A complex scene with several grayscale and segmented data sets
  - 3D models, such as this scene:
    - MR dataset of an orange
    - a single section of the orange (in red)
    - the rest of the orange (in orange)
Viewing Volumes (1 of 5)

- Slicer has multiple ways to display image volumes.
- Default is **Normal** view: two sections.
  - Upper portion: 3D formatted version.
  - Lower portion: 2D multi-plane formatted version.
Viewing Volumes (2 of 5)

- **3D** view: focuses on 3D.
Viewing Volumes (3 of 5)

- **4x512** view: larger image views to see details
Viewing Volumes (4 of 5)

- **1x512** view: one large, three small images.
Viewing Volumes (5 of 5)

- **4x256** view: smaller equal-sized images.
2D Viewer (1 of 3)

- Three 2D windows (red, yellow, and green).
  - Both grayscale and label map images in windows.
- Slider selects which slice of volume to display.
  - Field shows the slice number.
- V toggle button controls whether slice is visible in 3D Viewer.
  - Here, only slice from green window is visible in 3D Viewer.
2D Viewer (2 of 3)

- **Or** (scan order): changes scan order in each 2D window.
  - Example, Axial view in red window, Coronal in yellow, and Saggital in green.
- **Bg** (background): displays volume in background layer.
- **Fg** (foreground): displays volume in foreground layer.
  - Superimposed over the background layer.
2D Viewer (3 of 3)

- **Lb** (label map): displays label map in label map layer.
  - Displays results of a segmentation.
  - Images in the label map layer appear as outlines around the structures that were segmented.
  - Slicer can create label maps and models.
Adjusting Window/Level

- Optimizes display of the region of interest of gray-scale images.
- Click **Volumes** on **Main** menu.
  - **Volumes** panel appears.
- Select the **Display** tab.
- From **Active Volume** pull-down menu, select a volume.
- Adjust **Win** so that dark areas are black, not gray.
- Adjust **Lev** until dark areas become barely visible.
- Can also click **Auto**.
Color Palette

- Selects color scheme to colorize a gray-scale volume.
  - Helps distinguish different regions of interest better.
- Click **Volumes** on **Main** menu.
  - The **Volumes** panel appears.
- Select the **Display** tab.
- From **Palette** pull-down menu, select one of seven color schemes:
  - **Gray**, **Iron**, **Rainbow**, **Ocean**, **Desert**, **InvGray**, or **Label**.
Image Fusion

- Fades from background (Bg) layer image to foreground (Fg).
  - Useful for checking alignment.
  - Or coverage of a label map.
- Use **Fade** vertical slider (lower left of **Menu** window).
- Above: background images are grayscale and foreground images are label map.
Exercise: Viewing 2D (1 / 5)

• Load the I.001 volume as in previous exercise.
• Click V on Red, Yellow, Green 2D views.
• Select the view:
  – View → 3D: Examine 3D view.
  – View → 4x512: Examine large views.
  – View → 1x512: Examine single large view that rendered in red panel.
  – View → 4x256: Examine smaller views.
  – View → Normal: Examine normal view.
  – View: try Black, Blue, Midnight, White.
Exercise: Viewing 2D (2 / 5)

- Click green **V** button: image is visible in 3D Viewer.
- Use green slider to select the slice.
- Click **Or**, then select scan order in each 2D window.
- Click **Bg** to select the background layer.
- Click **Fg** to select the foreground layer.
Exercise: Viewing 2D (3 / 5)

- Click **Volumes** on **Main** menu.
- Select the **Display** tab.
- From **Active Volume** pull-down menu, select **I** volume.
- Adjust **Win** so that dark areas are black, not gray.
- Adjust **Lev** until dark areas become barely visible.
- Examine view.
- Try clicking **Auto**.
Exercise: Viewing 2D (4 / 5)

• Click **Volumes** on **Main** menu.
• Select the **Display** tab.
• From **Palette** pull-down menu, select color scheme.
• Observe how 2D view changes.
Exercise: Viewing 2D (5 / 5)

- Use **Fade** vertical slider (lower left of **Menu** window).
- Fade from background (**Bg**) layer image to foreground (**Fg**).
Viewing 3D Models

- **Display** tab of **Models** panel.
  - Which models are visible.
- Click **Show All** to display all models in the **3D Viewer**.
- Click **Show None** to display none of the models in the **3D Viewer**.
- Click name of model in the list to turn **Visibility** on and off.
- Right-clicking name of a model in the list displays a menu of display options for that model.
Controlling the 3D View

- To rotate the view:
  - Left-click the view and move the mouse.
- To move view left-right, up-down:
  - Click the middle button (or Alt-Left button) on view and move the mouse.
- To change the size of the view (zoom):
  - Right-click the view and move the mouse up and down.
Move the cursor over the Slicer icon.

The user interface panel appears.

Affects 3D Viewer.
User Interface Panel (2 of 2)

- **Fade** slider: fades between foreground and background.
- Click **R** (Right), **L** (Left), **P** (Posterior), **A** (Anterior), **I** (Inferior), or **S** (Superior) to align in that direction.
- Click up, down, left, and right arrows to rotate.
- **FOV**: Field Of View, the size of the image.
- **Spin**: rotates image horizontally.
- **Parallel**: toggles between parallel and perspective projection.
- **Scale**: scale for parallel projection.
Opacity of Model

- Opacity: how non-transparent a model is.
  - The higher the opacity, the less transparent.
  - Default: Slicer creates perfectly opaque models (opacity=1).

- Two ways to change opacity:
  - On the **Display** tab of the **Models** panel, adjust **Opacity** slider next to the model's name in the model list.
  - On **Props** tab of **Models** panel, set **Active Model**, and use **Opacity** slider.
Color of Model

- You can select colors for models.
- Click **Models** on **Main** menu.
  - The **Models** panel appears.
- Select the **Props** tab.
- Click **Color**.
- Enter a description of what that color will represent.
Exercise: Viewing 3D (1 / 5)

- Load model as in previous exercise.
- Click **Models** button on **Main** menu.
- Click **Display** tab: observe which models are loaded.
- Click name of model: turn **Visibility** on and off.
- Right-click name of model: observe display options for that model.
Exercise: Viewing 3D (2 / 5)

- Left-click 3D view and move mouse:
  - Rotates the view
- Click middle button (or Alt-Left button) on 3D view and move mouse:
  - Moves view left-right, up-down.
- Right-click 3D view and move mouse up and down.
  - Changes size of view (zoom).
Exercise: Viewing 3D (3 / 5)

- **User Interface Panel**: bottom of **Main** window.
  - Move cursor over the Slicer icon.
- Move **Fade** slider: fades between foreground and background.
- Click **Right**, **Left**, **Posterior**, **Anterior**, **Inferior**, or **Superior** to align in that direction.
- Click **up**, **down**, **left**, **right** arrows to rotate.
- Enter **FOV**: changes the size of image.
- **Parallel**: toggles parallel/perspective projection.
- **Spin**: rotates image horizontally.
- **Scale**: changes scale: larger for smaller image.
Exercise: Viewing 3D (4 / 5)

• First way to change opacity:
  – Click **Models** button.
  – Click **Display** tab.
  – Adjust **Opacity** slider.

• Second way to change opacity:
  – Click **Models** button.
  – Click **Props** tab.
  – Select **Active Model**.
  – Adjust **Opacity** slider.
Exercise: Viewing 3D (5 / 5)

- Color of model:
- Click **Models** on **Main** menu.
- Select the **Props** tab.
- Select **Active Model**.
- Click **Color**.
- Select color.
- Click **Apply**.
Clipping Models

- Clipping: cutting away sections of a model at one or more selected slices.
- The model is removed from one side of each selected slice, revealing the image of each selected slice and the rest of the visible model.
- On the **Display** tab of the **Models** panel, right-click the model's name in the list.
  - A drop-down menu appears.
- Select **Clipping**.
- Select the **Clip** tab of the **Models** panel.
- Select which side of a slice to clip the model on.
Clipping Example

- Click + or - to select which side of each slice to clip on.
- In this example, the right-superior-posterior part of the cortical surface has been clipped.
Exercise: Clipping Data

- Load model as in previous exercise.
- Click **Models** button.
- Click **Display** tab.
- Right-click the model's name in the list.
- Click **Clipping** to turn clipping on.
- Click **Clip** tab.
- Click + or - to select which side of each slice to clip on.
Modifying Data

- Slicer has many tools for manipulating and modifying data.
- Many tools start the same way:
  - On **Main** menu, click **Editor**.
    - The **Volumes** tab appears.
  - Click **Start Editing**.
    - The **Effects** tab appears.
  - Select tool.
  - Select **Input Volume**.
  - Select slices to modify: **Scope** and **Interact**

---

Surgical Planning Laboratory
http://www.slicer.org

Brigham and Women’s Hospital
Segmentation

- Segmentation: separating and labeling anatomical structure images.
- Result is a label map.
- Semi-automatic process using editing tools.
  - Include thresholding, morphological operations, island-removal, and free-hand drawing.
  - Segment data in 3D or slice-by-slice.
- Merge volumes to construct complex images.
- Example: segment skin from an MR scan.
Segmenting Data

- On the **Main** menu, click **Editor**.
  - The **Editor** panel appears.
- Click the **Volumes** tab.
  - The **Volumes** tab appears.
  - Click **Setup**.
    - The name of data appears in **Original Grayscale** field.
    - Select **NEW** for the **Working Labelmap**.
    - Enter name for this segmentation.
      - Example: "ventricles".
    - Click **Start Editing**.
      - The **Effects** tab appears.
Threshold Tool

- **Threshold**: automatically outlines structures based on voxel value.
- **Lo** slider: excludes low-intensity voxels.
- **Hi** slider: excludes high-intensity voxels.
- Click **Output** and select a color, or enter an **Output** color number.
- Click **Apply**.
  - The outlined areas are called "islands".
Results of Thresholding

- This example is segmenting CT skull bone.
- Thresholding has changed the label to blue.
- Notice that the skull is well-defined and separated from the rest of the image.
Exercise: Thresholding (1/2)

- Load volume as in previous exercise.
- Click **Editor** button.
- Click **Volumes** tab.
- Click **Setup** button.
- On **Original Grayscale** drop-down list, select volume.
- Select **NEW** for the **Working Labelmap**.
- Enter “Descriptive Name”.
- Click **Start Editing**.
Exercise: Thresholding (2/2)

- Click **Threshold** or **Th**.
- Click **Output**, select a color for selected voxels.
- Use **Lo** slider to exclude low-intensity voxels.
- Use **Hi** slider to exclude high-intensity voxels.
  - Example: if 140 is a common value on **2D Viewer**, let **Lo**=130 and **Hi**=150.
- Choose **Scope**: **1 Slice** or **3D**.
- Choose to filter **1 Slice**, **3 Slices**, or **3D**.
- Click **Apply**.
- Result: label map.
Change Label Tool

- Changes the value of the label of pixels to another value.
- Useful when merging two data sets together, and you want to keep the data sets distinct from each other.
- Click **Change Label**.
- Enter **Value to change**.
- Click **Output** and select a color, or enter a color number.
- Click **Apply**.
- The new output color will replace the value.
Exercise: Change Label

- Use on label map or original volume.
- On **Editor, Effects** tab, click **CL** or **Change Label**.
- Enter **Value to change**.
- Click **Output** and select a color.
- Choose **Scope**: **1 Slice** or **3D**.
- Click **Apply**.
- The new output color replaces the value.
Change Island Tool

- Changes color of an island*.  
  - *Island: a group of connected pixels with the same label.
- Useful after thresholding, to separate anatomy further.
- Click Change Island.
- Click New Label and select a color, or enter a color number.
- Click any part of the island.
- Pixels that are part of that island will receive the New Label value.
Change Island Example

- Before
- After
Exercise: Change Island

- Use on island in label map or original volume.
- On **Editor, Effects** tab, click **CI** or **Change Island**.
- Click **New Label** and select a new color.
- Click any part of the island.
- Changes island to **New Label** value.
Measure Island Tool

• Calculates the volume of an island of pixels.
• Click **Measure Island**.
• Click **Island Label** and select a color, or enter a color number.
• Click any part of the island.
• Slicer will display the **Size**, in pixels.
• Also displays the size of the **Largest** island within the selected **Scope**.
Exercise: Measure Island

- Use on island in label map or original volume.
- On **Effects** panel, click **Measure Island**.
- Click **Island Label** and select pixel color.
- Select **1 Slice** or **3D** for **Scope**.
- Click any part of the island.
- Observe **Size** of island in pixels.
- Observe size of **Largest** island within **Scope**.
Erode & Dilate Tool

- Removes pixels at border of all islands.
- Separates two partially connected structures; removes many small islands.
- **Dilate**: adds pixels around all islands.
- Click **Erode**.
- Click **Value to Erode** and select color, or enter color number. **Erode** acts only on pixels with selected color.
- **Fill** value: 0.
- **Iterations**: number of times to apply.
- **Neighborhood Size**: 4 for less erosion, 8 for more.
- Click **Erode**, **Dilate**, **Erode & Dilate**, or **Dilate & Erode**.
Erode Example

• Before                                  After

Surgical Planning Laboratory
http://www.slicer.org

Brigham and Women’s Hospital
Exercise: Erode & Dilate

- Use **Threshold** to change values: use vivid color.
- Click **V** for green 2D image.
- **Editor → Volumes** tab → **Start Editing**
- **Effects** tab: **Green Active Slice**, **Erode**.
- **Value to Erode**: use **Threshold** value.
- **Scope**: **3D**
- Click **Dilate**: threshold value spreads.
- Click **Erode**: threshold value area shrinks.
• **Draw**: specifies pixels for segmenting by drawing directly on them.
• Useful when automatic methods cannot segment data correctly.
• Click **Draw**.
• Click **Output** and select a color, or enter color number.
  – Pixels you draw on get this color.
• **Point Radius**: fineness of line.
  – 1 or 2 selects individual points.
• **Mode**: behavior of left mouse button.
  – **Draw**: for drawing on points.
  – **Select**: for selecting points.
  – **Move**: for moving selected points.
Draw Tool (2 of 2)

- **Select All**: selects all points.
- **Deselect All**: deselects all points.
- **Delete Selected**: deletes selected points.
- **Delete All**: deletes all points.
- **Shape**: shape of left mouse in the draw window.
- Draw on the region of interest (ROI) with left mouse button.
- Click **Apply**.
  - Slicer will fill the ROI with the **Output** color.
- Mistake? Use **Draw** with **Black** output to erase.
- Delete last selected point of polygon with **Delete Selected**.
Exercise: Draw

- Load volume.
- **Editor → Volumes** tab → **Start Editing**
- **Effects** tab: **Green Active Slice, Draw**.
- Click **Output**: select color.
- On **2D Viewer**, choose area to draw around.
- Click mouse on edge of area.
- Move mouse around area, clicking as you move.
- When area outlined, click **Apply**.
- Area is covered by selected color.
Remove Islands Tool

- **Remove Islands**: Automatically removes areas based on size.
- Useful for removing small areas that should not have been thresholded.
- Example: use an area of 10 to remove all islands less than 10 voxels in size.
Exercise: Remove Islands

- Use **Threshold** on volume.
- Click **Remove Islands** or **RI**.
- **Min. Island Area**: 10
- **Label of the sea**: 0
- **Scope**: 3D
- Click on **2D Viewer** in sea (outside island).
- Eliminates the smaller islands.
Save Island Tool

- **Save Island** retains the selected island, and removes disconnected pixels with the same label.
- Useful for separating a single connected structure from other structures.
Exercise: Save Island

- Color some voxels using **Threshold** or **Draw**.
- Click **Save Island** or **SI**.
- **Scope: 3D**
- Click an island in **2D Viewer**.
  - Warning: all other same-colored islands disappear.
Saving Segmented Data

- Segmented data: a label map
- On the Main menu, click Editor.
  - The Editor panel appears.
- Click the Volumes tab.
- The Volumes tab appears.
- Select Save.
- Select the name of your label map for Volume to Save.
- Select a file name.
  - Simplest to use same name as the Volume to Save.
- Save file to the appropriate directory.
Exercise: Saving Label Map

- Use any of the previous methods to create a simple label map.
  - Example: **Threshold**.
- Click **Editor → Volumes tab → Save**
- Select the **Volume to Save**.
- Add file name to end of **Filename Path**.
- Click **Save**.
Manual Registration

- Registration: aligning two medical images together.
- Click **Data** on the **Main** menu.
  - The **Data** panel appears.
- Select volume(s) and/or model(s) to move.
- Click **Data**.
- Click one volume.
- Click **Add Transform**.
- Click **Alignments**.
- Click **Manual**.
- Use the translation and rotation sliders to align one image with the other.
Automatic Registration

- Slicer can perform automatic registration.
- Automatic registration can use manual registration as starting point.
- Click **Alignments**.
- Click **Auto**.
- Select matrix created by manual registration.
- Select the reference volume and the volume to move.
- Click **Run**.
- Automatic registration will run. This will take a few minutes, including initialization and a series of displays that appear and disappear.
Exercise: Registration

- Load volume from spgr folder.
- Load label map from labels folder.
- Use as Fg and Bg.
  - **Toggle** between them to show misaligned.
- Click **Alignments → Auto**.
- Select **Volume to Move** and **Reference Volume**.
- Click **Intensity → Good and Slow**.
- Click **Start**.
  - This can take a long time.
Making Models

• Model: a three-dimensional surface.
• Use output of segmentation process (label maps) to create models.
• The bounding surfaces of the label maps are extracted and represented as a collection of triangles.
• Decimation reduces the number of triangles:
  – can be rendered more quickly
  – little observable loss in detail
  – example: a typical brain surface is reduced from about 500,000 triangles to 150,000.
From Label Map to Model

- Click **ModelMaker** on the **Main** menu.
- On **Create** tab of **ModelMaker** panel, use the **Volume** pull-down menu to select label map.
  - Largest label in this volume is automatically selected.
  - Or click **Label** to select another color, or enter the label value in the field.
- Enter a **Name** for the model.
- Change values of **Smooth** and **Decimate** parameters.
- Click **Create** and wait for the model to be created.
  - The model will appear in the **3D Viewer**.
Model Example

• Before

After
Exercise: Making a Model

• Load label map.
• **ModelMaker → Create** tab.
• Select label map from **Volume** pull-down menu.
• Select **Label** to model (smaller area = faster).
• Enter a **Name**.
• Enter **Smooth** (larger = faster, smoother).
• Enter **Decimate** (larger = slower, fewer triangles).
• Click **Create**.
• To save: **Save** tab, click **Save**.
Manipulating Model

- The model appears in the **3D Viewer**.
- Rotate the model: with left mouse button.
- Translate the image: with middle mouse button (or Alt-Left button).
- Zoom the image: with right mouse button.
- Hide and unhide the model: click name of model on the **Models** panel.
- Change opacity of model: use sliding scale next to name of model on the **Models** panel.
Saving Data

- Slicer can save data in many ways.

- Save Scene
- Save Scene As...
- Save Scene With Options
- Save Current Options
- Save 3D View
- Save Active Slice
- Save 3D View As...
- Save Active Slice As...
Saving Volumes

- After creating new label map data, it may be necessary to save the new volume of data.
- On the Main menu, click Editor.
  - The Volumes tab appears.
- Click Save.
- From the menu, select the label map to save and click Save.
  - The Save Volume dialog box appears.
- Select the path and click Save.
Saving Models

• On the **Main** menu, click **ModelMaker**.
• Click the **Save** tab.
• From the menu, select the model to save and click **Save**.
  – The **Save Model** dialog box appears.
• Select the path and click **Save**.
  – The model will be saved as a .*vtk* file, which identifies the file as a model.
Saving the Scene

• There are several ways to save the scene in Slicer.
• Use **Save Scene** to save as an XML file.
  – The XML file lists the elements of the scene and their attributes.
• Use **Save 3D View** to save a picture of the 3D View.
• Use **Save Active Slice** to save one slice.
• Use **Save Current Options** to save user preferences, like background color or view presets, into a special `Options.xml` file.
Save Scene

- You can save a description of the current scene.
  - Includes pathnames to the volumes and models.
  - Can later open them all, just by opening the scene file.
- Before saving scene, save any new volumes and models.
- Click **File**.
  - A drop-down menu appears.
- To save file with default file name (**data.xml**) and no options, select **Save Scene**.
- To use another file name, select **Save Scene As** and enter file name for the scene.
- Use **Save Scene With Options** to include options in the scene description.
Opening a Saved Scene

- Click **File**.
- Click **Open Scene**.
- Find the scene `.xml` file, double-click it, and wait for the volumes and models to load.
Save Images

- You can save 3D View or Active Slice as TIFF files.
  - Active Slice: the one that you clicked on last.
- To save the 3D View:
  - Click File.
  - A drop-down menu appears.
  - To save with default file name, select Save 3D View.
  - Or select Save 3D View As and enter file name.
- To save the Active Slice:
  - Click File.
  - A drop-down menu appears.
  - To use default file name, select Save Active Slice.
  - Or select Save Active Slice As, enter file name.
Save Current Options

• You can save your preferences, including:
  – **View Presets** set under the Slicer graphic in the **Menu** window.
  – Settings from the **Modules** tab on the **Options** panel.
  – **Background Color** set using **View**.
• Click **File**.
  – A drop-down menu appears.
• Click **Save Current Options**.
  – Saves preferences to a file named *Options.xml* in the current directory.
  – When running Slicer from that directory, it will use your saved preferences.
Extending Slicer

- Slicer is modular.
- You can extend Slicer by adding new modules.
- See Developer’s Guide for more information.