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3D Visualization of the Anatomy

®

Following this tutorial,
you will be able to load
and visualize volumes
within Slicer4, and to
interact in 3D with
structural images and
models of the anatomy.
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®

3DSlicer

Powerful processing. | Streamlined interface.

Extensible platform.

Slicer is a freely available open-
source platform for segmentation,
registration and 3D visualization of
medical imaging data.

3DSlicer is a multi-institutional effort
supported by the National Institute of
Health.

©2012-2014, NA-MIC ARR
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3DSlicer

®

* An end-user application for
image analysis

* An open-source environment
for software development

» A software platform that is both
easy to use for clinical
researchers and easy to extend
for programmers
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www.slicer.org

®

®eno - - - - 3D Slicer

[« [ > ] [+ [Entp:/ jwwwsicer.org/ ¢ Ji(Q- Google )
L Slicer
b li A multi-platform, free and open source software package for
. \ 3DS icer visualization and medical image computing
. 4
] ] . Download | Tutorlals  Reference | Feedback
IS a mMult-platiorm
uuuuuuuuuu
L Powerful processing. eal Extensible platform.
AAAAA Slicer | okl
sortware running on - =
nnnnnnnnnnnnnnnn
aaaaaaaaa

Windows, Linux,
and Mac OSX.

Disclaimer

It is the responsibility of the user of 3DSlicer to comply with both the terms of the license
and with the applicable laws, regulations and rules. Slicer is a tool for research, and is
not FDA approved.

©2012-2014, NA-MIC ARR Slide 5



‘ﬁb 3DSlicer History

Image Courtesy of the CSAIL, MIT

1997: Slicer started as a
research project between the
Surgical Planning Lab (Harvard)

and the CSAIL (MIT)

©2012-2014, NA-MIC ARR
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3DSlicer History

®

« 1997: Slicer started as a
research project between the
Surgical Planning Lab (Harvard)
and the CSAIL (MIT)

Extensible platform.

Y.
\ VO »
¢ " -~ .

o 2012: Multi-institution effort to
share the latest advances in
Image analysis with clinicians
and scientists
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NA-MIC and NAC

NA-MIC Wiki

General
»Overview
»Organization
»Contact Us

Center Components
»Algorihms

»Engineering

»Drving Biological Projects
»Colaboration Grants

Resources
»Publication DB
»image Gallery
»Downloads
»Service
»Training
»Dissemination
»Events.
»Links

National Alliance for Medical Image Computing
A National Center for Biomedical Computing
Funded under the NIH Roadmap Initiative

(GOt Custom Search] ST

Neuroimage Analysis Center

"understanding the human brain through imaging”

About the NAC
»Overview

W »Organization
RSNA 2011 »Research Cores
B st »Collaborations
97th Scientific Resources
»Contact Us

Assembly and

. »Publication DB
Annual Meeting

»Image Gallery
»Downloads
»Training Materials
»Web Archive

November 27 - December
2, McCormick Place,

0 Read more.

0 NEWS ARCHIVE

1 0f 23 Photos

The Natlonal Alllance for Medlcal Image Computing (NA-MIC) is a

y team of p scientists, software
engineers, and medical ir who develop { tools for
the analysis and visualization of medical image data. The purpose of the
Center is to provide the infrastructure and environment for the
development of computational algorithms and open-source technologies,
and then oversee the training and dissemination of these tools to the
medical research community.

Supported by the National Institutes of Health, Roadmap Initiative.

Information about collaborating with NA-MIC is available on our wiki.

)¢ W’&@ )

Control Group DDC Group

State-space Models of Mental Processes from fMRI
Spatial Maps. The sverage cors mape of e o groups (vaxskwise group sverage divded by group sid.

dav.) are displayed on an Inflsied braiv-surface (af ltaral-posteror, o mediakpostrir, ight terior and right
lateral-posterior). Each row shows the maps for one phase of the task and values t < 3 have been masked out for clarity.

»»More...

»>Featured Image Archive

The Neuroimage Analysis Center (NAC) develops image processing and analysis techniques for
basic and chnlcal neurosciences. The NAC research approach emphasizes both specific core

ion projects. The activities of the NAC are centered at the
Harvard Medlcal School and the Surgical Planning Laboratory at the Brigham and Women's
Hospital in Boston, with collaborators throughout the United States and the rest of the world.

The NAC is a major research center supported by the National Center for Research Resources

(NCRR), a component of the National Institutes of Health.
D YEH
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Slicer: Behind the scenes

§ Safari File Edit View History Bookmarks Window Help GO M S <) @ 11:07AM Q
CDash - Sicer4
+ |€ http:/ /www.cdash.org/slicer4 /index.php?project=Slicer4 ¢ Q- Google

Login All Dashboards Doo N o208 00

Slicer4

S . . u .
Dashboard Calendar Previous Current Project I I C e r I S b I I t e V e
'WARNING: This CDash instance is running the bleeding edge svn trunk CDash code, and is updated frequently. You | ry

1 file changed by 1 author as of Sunday, November 27 2011 - 22:00 EST

nlght on WindOWS,

Windows7-VS2010-32bits-QT4.7.1-PythonQt-With-Tcl-CLI-

factory-win7 Kitware Roloase @ 107 .
factory-mac-64bits.kitware SnowLeo?erqg++4.2. 1-64bits-QT4.7-PythonQt-With-Tcl-CLI-
Release W&
factory-ubuntu-64bits.kitware LS:*Q»M.4.3«54bns—QTA47-Py!nonQt—wilh-Tcl—CLl-Relaase
factory-win7.Kitware VWHWWSZ-VS\ZOOG-S“DWS—QTL[‘I -PythonQt-With-Tcl-CLI-
Release &/
factory-win7.kitware Wmdows?-VSZOOB-GZMB—QT‘QJJ -PythonQt-With-Tcl-CLI-
Release %

site Build Name Build Time
whitecube kitware & SnowLeopard-gocd.2.1-Qt4.7.0-PythonQt-With-Tel-Release 11 hows ago
@
. OpenSuse-c++4.5.0-64bits-QT4.6.3-PythonQt-With-Te-NoCLI- T
Release
eris itware Linux-g++4.4-QT4.6.3-PythonQt-CLI-Release 3 hours ago
e Iinx(«y-m.4,3-QT4.7-Pymoan-W’nh-Tcl-CLI-Valgvind—Relsase .,
factory-ubuntu-64bits Kware Linux-g++4.4.3-64bits-QT4.7-PythonQt-With-Tcl-NoGLI- 11 hours ago

Coverage-Release
sagarmatha.kitware Linux-g++4.3.3-QT4.7-PythonQt-With-Tcl-NoCLI-Release 12 hours ago

Build Time

OpenSuse-c++4.5.0-64bits-QT4.6.3-PythonQt:

1 hour ago
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N Slicer Training

* Hands-on training
workshops at national
and international
venues (MICCAI,
SN, OHBM, RNSA..)

o >2 000 clinicians,
clinical researchers
and scientists trained
since 2005
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3DSlicer version 4.1

e Modules ) Welcome to Slicer O Bl ¢t~ » B e S -
r;\ >Slicer
< 4
==y Load DICOM Data Easy Load Data
#: Customize Slicer @ Download Sample Data
» About

» The Main Window

» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

~ Data Probe

L
F
B

None RAS: (125.0, -125.0, 1.0),
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Welcome to Slicer4

ga ga |Modules 2\ Welcome to Slicer

YO ad 2 @gv »@_1‘.,:@‘
e= [

B osiicer /
(s Load DICOM Data [y Load Data
@ Customize Slicer @ Download Sample Data
» About

» The Main Window

» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

~ Data Probe

L
F
B

None RAS: (125.0, -125.0, 1.0),

©2012 2014, NA-MIC ARR

Slicer is built upon a modular architecture.
The Welcome to Slicer module is displayed
by default at start-up.

Click on Welcome to Slicer to display the
103 modules of Slicer in the Modules menu
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ACPC Transform
Add Images.
2 Annotations
BSpline to deformation field
Cameras

Cast Image
ChangeTracker
CheckerBoard Filter
Colors

Create a DICOM Series

Crop Volume

Curvature Anisotropic Diffusion
DICOM

DWI to Full Brain Tractography

i EMSegmenter with Atlas
& EMSegmenter without Atlas

Editor
Endoscopy

Event Broker

Execution Model Tour

Expert Automated Registration
Extract Skeleton

t Multiresoiution Affine Registration
tistics Segmentation

General Registration (BRAINS)
Gradient Anisotropic Diffusion
Grayscale Fill Hole
Grayscale Grinid Peak ]
Grayscale Model Maker « Scene Views
Histogram Matching Simple 0 Test
Image Label Combine Simple region
Intensity Difference Change Detection (FAST)
int Rician LMMSE Image Filter
Label Map Smoothing
Label Statistics
Linear registration
MR Bias Field Correction
Mask Image Tractography Labelmap Seeding \
WMasictrom Diffsio Weighied images Transform MRML Files to New EMSegmenter Standard i
M % Transforms
Unbiased Non Local Means filter for DWI g
View Controllers }
® Volume Rendering
@ Volumes 40
Voting Binary Hole Filling 3
elcome 10 Slicer

Resampl
Resample Scalar Volume

Resampie Scalar/VeclorfOWi Voiume
Rician LMMSE Image Filter

Slicer4 contains more
than 100 modules for
Image segmentation,
registration and 3D
visualization of
medical imaging data

©2012-2014, NA-MIC ARR

Slide 13



SPL

PART 1: LOADING AN MR
VOLUME




‘ﬁ' The DICOM 3.0 File Format

Most radiological imaging equipment produce images
in DICOM file format (‘.dcm files’)

.
L Image001.dcm

Header

Image002.dcm

Raw Data

Image003.dcm

©2012-2014, NA-MIC ARR Slide 15



‘ﬁ' Data Representation

--.ii--ll

 The result of a volumetric

acquisition is a 3D volume of
data related to the patient.

« The 3D raster dataset is

sampled on a discrete grid
with elements called voxels
which contain the signal
Intensity.

©2012-2014, NA-MIC ARR
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‘ﬁ' Tutorial Dataset

The tutorial dataset is an MR
scan of the brain of a healthy
subject.

The data in the Nrrd file format,
part of the NA-MIC open-source
toolkit

DICOM data can be converted in
Nrrd using the module ‘DICOM to
NRRD Converter’ in Slicer.

©2012-2014, NA-MIC ARR
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Slicer4

& |Modules: . [@Welcome to Slicer s = TP e«d 2 o)t~ " B R M
o [l
;@ 3DSlicer
(=5 Load DICOM Data ik Load Data 7

& Customize Slicer @ Download Sample Data C I I C k o n LO a d

» About
n L

» The Main Window Data II l tI le : ;IIC‘ ,r
» Loading and Saving
» Display
» Mouse & Keyboard We I CO e O d u | e

» Documentation & Tutorials

SR AW

» Acknowledgment

~ Data Probe

L
F
B

None RAS: (125.0, -125.0, 1.0),
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Loading a volume

& Slicer SO M= ) @ 545PM Q

3D Slicer 4.1.0-rc1-2012-03-15

QI PO ed 2 P

ga |Modules ) Welcome to Slicer

-

- » B e e -

3DSlicer

Welcome

(@5, Load DICOM Data [eeiy Load Data
@ Customize Slicer @ Download Sample Data
» About
- 8No Add data into the scene |

*» The Main Window
— |Choose Directory to Add|{Choose File(s) to Add Show Options

» Loading and Saving v File ~ Description

» Display " v [Users/spujol/data/dataloading_and_visualization/MR-head.nrrd Volume E]

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

@OK || X Cancel

Click on Choose File(s) to Add

~ Data Probe

[ N

©2012-2014, NA-MIC ARR Slide 19



Loading a volume

& Slicer GO M= ¢) @& 545PM Q
00 3D Slicer 4.1.0-rc1-2012-03-15

&3 |Modules: . [@Welcome to Slicer dm 00N el@ s ‘;‘ 4~ ) A R | 47
o®

E 3DSlicer
Welcome

(s Load DICOM Data | sy Load Data ]
@ Customize Slicer @ Download Sample Data \
[» About L A
— 0 0 ol8I0e Open
[» The Main Window Choost Look in 3 /Users/spujol/d...d_visualization | © @ @ (] [E] ptions 7
|» Loading and Saving = A spujic| Name Stion

o MR-head.nrrd
[» Display & ead.nrr

| » Mouse & Keyboard

[ » Documentation & Tutorials 1 \

[ » Acknowledgment | N

< v (4] D)
File name MR-head.nrrd -

Browse to the location of the Visualization directory and select the
file MR-head.nrrd

[~ Data Probe

L
F
B
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Loading a volume

& Slicer GO M G 545 Q
3D Slicer 4.1.0-rc1-2012-03-15
ga |Modules: . [@Welcome to Slicer ™ QO INPO &« ot » S v
[BY soslicer
g
(@5, Load DICOM Data [eeiy Load Data
@ Customize Slicer @ Download Sample Data
» About 2
- 8no Add data into the scene
» The Main Window
— |Choose Directory to Add|[Choose File(s) to Add Show Options
» Loading and Saving 1@ File ~ Description
» Display | v /Users/spujol/data/dataloading_and_visualization/MR-head.nrrd Volume E]
» Mouse & Keyboard
B AN
» Documentation & Tutorials | \ .
\
» Acknowledgment | \

L Reset @OK | X Cancel

Click on OK to load the MR dataset into Slicer

~ Data Probe

[ N
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Loading a volume

& £a Modules: -, [@Welcome to Slicer dm 00 INP O eald 2 /E] 4~ »| @ A Ra |4~

e @1
@ 3DSlicer

Welcome

| =% Load DICOM Data || [y Load Data
( & Customize Slicer || @ Download Sample Data
| » About

|» The Main Window

[» Loading and Saving

| » Display

[» Mouse & Keyboard

[» Documentation & Tutorials

| » Acknowledgment

The axial, sagittal and
coronal views appear
in the 2D viewers.

L
F
B
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Loading a volume

3D Slicer 4.1.0-rc1-2012-03-15

‘000

ga £a |Modules: . [@Welcome to Slicer "0 QIN PO @ « @ t - » o

@®
@ 3DSlicer

Welcome

[ Load DICOM Data || sy Load Data ]
[ ®c ize Slicer || @ Do Sample Data |
[» About

[» The Main Window

[» Loading and Saving

| » Display

[» Mouse & Keyboard

[ » Documentation & Tutorials

[» Acknowledgment

©2012-2014, NA-MIC ARR Slide 23



Loading a volume

8006 3D Slicer 4.1.0-rc1-2012-03-15
ga £a |Modules: -, [@ Welcome to Slicer " 00 NP el 2 E‘ ot » Ao Fa |4~
e i [E Conventional

Ef Conventional Widescreen
[E Conventional Quantitative

@ 3DSlicer

B Four-Up
We I come B Four-Up Quantitative

B8 Dual 3D
& Triple 3D

[ Load DICOM Data | ey Load Data Dpon\y

( 4 Customize Slicer || @ Download Sample Data [ Red slice only
= Yellow slice only

[» About [ Green slice only

| » The Main Window = Tagzeg 3ID
abbed slice
| » Loading and Saving B Compare R

[» Display
| » Mouse & Keyboard

| » Documentation & Tutorials

[» Acknowledgment

Select Red slice
only layout

E
B

©2012-2014, NA-MIC ARR

M Compare Widescreen
B Compare Grid

B Three over three

[ Four over four

B Two over Two
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Loading a volume

800 3D Slicer 4.1.0-rc1-2012-03-15
&a IModules: -, [@ Welcome to Slicer DL QN9 add Blelt- » Ra R, -
e
{_\ » @ < |Axial 4 |[MR-head
) soslicer
4

Welcome

=z, Load DICOM D: e Load Data
# Customize Slicer @ Download Sample Data
» About

» The Main Window

» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

¥ ..
Position the mouse button at the top left corner of

the window to display the slice menu
R, S—

L
F
B
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Loading a volume

eno 3D Slicer 4.1.0-rc1-2012-03-15
& IModules: . [@Welcome to Slicer N QINMP O &« & ~ Hie t-~ » o Ra ¢
o I 1s:13.29
<« @ < | Axial cE oo, B 3@

{D >Slicer

= - ~| & [None
2 = @ |None
Welcome - [ & [Weas

5= Load DICOM D:
# Customize Slicer @ Download Sample Data

[y Load Data

» About

» The Main Window

» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

Click on the >> to expand the slice viewer menu

y
v Data Probe "

L
F
B
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Loading a volume

eNO
& |Modules: . [@ Welcome to Slicer

3D Slicer 4.1.0-rc1-2012-03-15
d= 009 e« <« Mt~ Y AEE

or DN
«| @ x| Axial s E o B 5 W

G|
= 1x3 view
eicome ® | [100]:
x4 view
1x6 view
=, Load DICOM Data ey Load Data 1x8 view
#: Customize Slicer @ Download Sample Data

» About

» The Main Window

» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

Click on the Lightbox view icon
In the slice menu, and select the

6x6 view option
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Loading a volume

Y G

3D Slicer 4.0.gamma-2011-11-24
%2 & Modules Welcome to Slicer | wm DO @« L@ Z » ﬁ & | § ~Persisten =)
B sosiicer

S >
[oicony L ICOM Data (e L
,ﬁgl.o 1 a ) Download Sample Data
About

i

Slicer display 36 consecutives
images of the dicom volume.
Use the red slice slider to
browse through the data
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Loading a volume

]
)
>

3D Slicer 4.1.0-rc1-2012-03-15

ocu) @ Modules: £\ Welcome to Slicer o

B Conventional Widescreen
[ Conventional Quantitative
Four-Up

B Four-Up Quantitative

E Slicer
Welcome

[ Load DICOM Data ooy Load Data
#: Customize Slicer @ Download Sample Data [T Red slice only
= Yellow slice only
» About @ Green slice only

Tabbed 3D

[ Tabbed slice
B Compare >
M Compare Widescreen » ’
B Compare Grid » i
i Three over three
[ Four over four

B Two over Two

» The Main Window

» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

Left click on the red window
icon, and select the
Conventional layout

©2012-2014, NA-MIC ARR
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Loading a volume

ga g& |Modules: ., [@Welcome to Slicer =00 IN PO &~ ol b~ » R,

Q s0sticer
Welcome . . .
st | Select the lightbox viewer in the

#: Customize Slicer @ Download Sample Data

red slice menu, and come back

» The Main Window

to 1x1 view

| » Display

| » Mouse & Keyboard \/ ‘\b

» Documentation & Tutorials

» Acknowledgment

|~ Data Probe

L
F
B
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Loadlng a volume

a-::i@Mdl . [®Welcome to Slice °'JO{D@0%£/_ @Etv > B R |
e [l
Q}l)shcer S
Welcome
| @& Load DICOM Data | [sac Load Datg !

e e Click on the links icon to link all

| » The Main Window

three viewers, and on the eye

| » Display

icon to display the slices in the

| » Documentation & Tutorials

[» Acknowledgment 3 D Vi eW e r

| ~ Data Probe

L
F
B
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Loading a volume

ga &a [Modules: . [@Welcome to Slicer

QoINS a@ -~ [EHiet-

:\—v
ex [li

Welcome

[ Load DICOM Data Load Data

The three
anatomical slices

appear in the
3DViewer

| ~ Data Probe

L
F
B
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Loadlng a DICOM volume

Welcome

Use the left-
mouse button to
rotate the

camera, and the
right-mouse

and out
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Close the scene

ga 24 2a |Modules: . [@Welcome to Slicer " 00N e«d s ol 4 B e
ex [l

Welcome

=5z Load DICOM Data 54, Load Data
#: Customize Slicer @ Download Sample Data £

Select File> Close Scene to

[» The Main Window

| » Loading and Saving

I the Slicer S
R CloSe tne olicer ocene
| » Documentation & Tutorials

[» Acknowledgment

R — —S: <1571 | -
n.

|~ Data Probe

©2012-2014, NA-MIC ARR
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Exit Slicer

@ Modules 2\ Welcome to Slicer

{'L\\ Slicer
=4
s Load DICOM Data e Load Data
# Customize Slicer @ Download Sample Data
» About

» The Main Window

» Loading and Saving
» Display

» Mouse & Keyboard

Select Slicer-> Exit to exit the

software

~ Data Probe

L
F
B

None RAS: (125.0, -125.0, 1.0),

©2012-2014, NA-MIC ARR
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Part 2:

3D visualization of surface
models of the brain

©2012-2014, NA-MIC ARR Slide 36



A Slicer scene is a MRML file which
contains a list of elements loaded into
Slicer (volumes, models, fiducials...)

 The tutorial scene contains an MR scan
of the brain and 3D surface models of
anatomical structures.

* The tutorial data are part of the SPL-PNL
Brain Atlas developed by Thalos et al.

©2012-2014, NA-MIC ARR Slide 37



Loading a Scene

) & |Modules: -, [@Welcome to Slicer (™m0 QINYO &« 2 ol ¢~ » S -

B® 1
BY soslicer
g
[y Load DICOM Data ey Load Data
#: Customize Slicer @ Download Sample Data
» About

» The Main Window

» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

Select File & Load Scene
from the main menu

~ Data Probe

L
F
B

None RAS: (125.0, -125.0, 1.0),

©2012-2014, NA-MIC ARR Slide 38



Loading a Scene

<]

(6]

2

3D Slicer 4.1.0-rc1-2012-03-15

o & |Modules: . [@ Welcome to Slicer

3DSlicer

Welcome

Load DICOM Data || Load Data

)

[ ®&c ize Slicer || @ Download Sample Data |

» About

Lookin: [Ea/Users/spujol/...ata/3DHeadData | & © @ F () [E)

» The Main Window

A spuic|  Name

» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

BN EEENENENE

©2012-2014, NA-MIC ARR
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Loading the Slicer Scene

& |Modules: . [@Welcome to Slicer " 00 IO el s ‘;‘ 4~ » Aa R | 4~

welcome A 3D surface model of the

( Load DICOM Data || [

emmse oo N€Ad, and 2D anatomical

[ » About

slices appear in the Viewer.

|» Loading and Saving

| » Display

| » Mouse & Keyboard

| » Documentation & Tutorials

| » Acknowledgment

| ~ Data Probe
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3D Surface Models

« A 3D model is a surface
reconstruction of an anatomical
structure.

®

« The model is a triangular mesh that

approximates a surface from a 3D
label map.

* The scalar values for surface models
are integers which correspond to the
label that had been assigned in the
segmentation process.
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Loading the Slicer Scene

B et~

> @ e Fa | v

ga &3 IModules: . [@ Welcome to Slicer ¢ 00 IN9P O & 7

@ 3DSlicer
Welcome

| =% Load DICOM Data || esy Load Data
( # Cl ize Slicer || @ Downlo: ple Data

[» About

[» The Main Window

[» Loading and Saving

| » Display

[» Mouse & Keyboard

[» Documentation & Tutorials

[» Acknowledgment

[~ Data Probe

L
c
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Models module

8006

D T —rL XYL The list of 3D
L 2l models appear in
the Models panel

=-Scene
# hemispheric_white_matter.vik
# left_eyeball vik
# optic_chiasm.vtk
# optic_nerve_L.vtk
# optic_nerve_R.vtk

» Information ‘

v Display ]

Visible: v
Selected:
Clip:
Slice Intersections Visible:
v Material Properties

Color: ( O

Opacity: 0[100]7]
Ambient: @ (0004
Difuse:

J[100]2
Specular: G [000 Eﬁ
Power: B [10 E:

Backface Culling: ¥,

Preview: ﬁ Presets:;y :m
L

» Scalars

» Clipping J

v Data Probe J

Yellow RAS: (0.0, 166.7, -67.1) Sagittal Sp: 1.0

| Neana
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3D Visualization

®

"% skull_bone.

» Information

~ Display
Visible: v
Selected:
Clip:
Slice Intersections Visible:

v Material Properties

Color: ( ] |
Opacity: 0
Ambient: @
Diffuse: &}
Specular: &
Pover

Backface Culling: v/

N o
R IS
L

> Scalars

» Clipping

v Data Probe

Yellow RAS: (0.0, 166.7,-57.1) Sagittal Sp: 1.0

| Neana
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3D Visualization

Yo¥e
| % & [Modules: . [@Models

g 3DSlicer

» Help & Acknowledgement

= Scene
= hemispheric_white_matter.vtk
= left_eyeball.vtk
= optic_chiasm.vtk

9

g

@

833

5
88888838

» opti ct_R.vtk

» right_eyeball.vtk
= skull_bone.vtl K

» Information

~ Display

Visible: v

Selected:

Clip:

Slice Intersections Visible:
v Material Properties
Color: ( [m] ]
Opacity: ;.
Ambient: C 10.00 |2
Diffuse: :.
Specular: 0 (0.00 4]
Power: s (1.0 4

Backface Culling: v
~ Data Probe

wmr
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3D Visualization

& Slicer File Edit View Help

B & |Moddes: o [@Modes |3 - QOIND

EE
@ 3DSlicer

[ » Help & Acknowledgement

= Scene

[ Information )

[ ~ Display ]
Visible: v
Selected:

Clip:
Slice Intersections Visible:
v Material Properties

Color: ( [m] )

Opacity: —_— (047
Ambient: 0
Diffuse:

Specular: &
Power: —_—
Backface Culling: v/

Preview:

, Scalars

[» Cipping

[+ Data Probe

Yellow RAS: (0.0, 166.7, -57.1) Sagittal Sp: 1.0

L None ()
F None ()
8 None ()
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3D Visualization

800
& & |Modules: . [@Models

@ 3DSlicer

» Help & Acknowledgement

= Scene
= hemispheric_white_matter.vtk 1.00
» left_eyeball.vtk | 100
= optic_chiasm.vtk 1.00
= optic_nerve_L.vtk 1.00
= optic_nerve_R.vtk 1.00
= optic_tract_L.vtk 1.00
= optic_tract_R.vtk 1.00
= right_eyeball.vtk B 1.00
= Skin.vtk 0.00
- _bone. W 1.00
Information
~ Display
Visible: v
Selected:
Clip:
Slice Intersections Visible:
v Material Properties
Color: ( ]
Opacity: 2[1.00 ]2
Ambient: 0 10.00 2]
Diffuse: (1007
Specular: @ m
Power: —_— 10 |

Backface Culling: v
~ Data Probe

wmrr
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3D Visualization

& Slicer File Edit View Help GO ™M=« @O Q
800 EDSlicedi0oanac20LI 1A
@ & |Modules: . [@ Models DR RS MEAN I WP ] »| BR @ t v pessent | @ Am Ra | 4~
1

EE)
@ 3DSlicer

[ » Help & Acknowledgement

®

= Scene
# hemispheric_white_matter.vtk
# left_eyeballvik
# optic_chiasm.vik
» optic_nerve_L vtk
# optic_nerve_R.vtk

888388888

# optic_tract_Avik
# right_eyeballvtk
# Sxinvik

’

8

§

i

8

s W‘r

S

| |

PRI

[» Information

[~ Display

Visible:

Selected:

Clip:

Slice Intersections Visible:
"+ Material Properties

Color: ( O |
Opacity: 7 @
Ambient: @ [@g
Diffuse: a[100[Z)
Specular: @ [000T

(n 12l

The 3D surface of them
white matter appears in
the 3D viewer
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3D Visualization

®

_ @& Slicer File Edit View Help % D m « @ 0O Q
eno 3D Slicer 4.0.gamma-2011-11-24
@ & |Modues @ Models = QO IO @ A @@ | 4 v Persistent fe So
= B

B®
{D 3DSlicer
4

[ » Help & Acknowledgement

= Scene

# hemispheric_white_matter.vtk 1.00
# left_eyeball.vtk . 100
# optic_chiasm.vtk 1.00
# optic_nerve_Lvtk 1.00
# optic_nerve_R.vtk 1.00
# optic_tract_Lvtk 1.00
# optic_tract_R.vtk 1.00
# right_eyeball.vtk W 100
# Skinvik 0.00
g 1 1.00 |
[ > Information
[+ Display
Visible:
Selected
Clip:
Slice Intersections Visible:
v Material Properties
Color:
Opacity: _— 1]
Ambient ———————[000[%
Diffuse: _— 1]
Specular: 2 210.00 (=4

Click on the eye icon in
the green viewer to
display the coronal slice
in the 3D viewer
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3D Visualization

0o

R & Moo oMot .- Select the 3D model

@®

& hemispheric_white matter.vik,

®

» Help & Acknowledgement = I h L C I L] . h
‘ and select the option Clip in the
sphe te i

= left_eyeball.vtk | 1.00 o

= optic_chiasm.vtk 1.00

= optic_nerve_L.vtk 1.00 IS p ay a

= optic_nerve_R.vtk .00

= optic_tract_L.vtk

» optic_tract_R.vtk 1.0t ;, U‘

= right_eyeball.vtk | 100 L

= Skin.vtk 0.00

<~ skull_bone.vtk 1.00 of

» Information

~ Display
Visible: v

Selected:
Clip: v
Slice Intersections Visible:

v Material Properties

Color:

Opacity: —_—1.00 ]
Ambient: 0.00 =
Diffuse: —ee[1.00 |2
Specular: 0.00 =
Power: 1.0 =
Backface Culling: v 3

~ Data Probe

L
F
B
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3D Visualization

Yo Xe)

- o e Gelect the tab Clipping, and set
B o the Green Slice Clipping to

» Information

Negative Space

Visible: v
Selected:
Clip: v
Slice Intersections Visible:

v Material Properties

®

Color:
Opacity:
Ambient:
Diffuse:
Specular:
Power:
Backface Culling: v
Preview: J Presets: i 3
» Scalars
~ Clipping
Clipping Type: ) Union @
Red Slice Clipping: *— Positive O &
Yellow Slice Clipping: © *  Positive © *
v Green Slice Clipping: © *— Positive ® £
~ Data Probe

L
F
B
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3D Visualization

= The optic chiasm appears

%t Modules:

s .. inthe 3D viewer

4

B s

» Information |

~ Display |
Visible: v
Selected:
Clip: v
Slice Intersections Visible:
v Material Properties

Color:
Opacity: 1.00 2
Ambient: —=—ox0.00 |
Diffuse: —_— (1002
Specular: e———u=[0.00 £
Power: (10 %
Backface Culling: v
Preview: g Presets: m
» Scalars

~ Clipping

Clipping Type: ﬂ Union @ (@, Intersection

Red Slice Clipping: *— Positive O +— Negative
Yellow Slice Clipping: © £ Positive © £ Negative

v Green Slice Clipping: © #— Positive @ £— Negative

~ Data Probe

T
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3D Visualization

@ Modules: @ Models N DA I A =2 I R

& -~ Uncheck the option
o clipping and lower the

= Scene

®

= left_eyeball vik

-+ opacity of the White Matter

= optic_tract_R.vtk

= right_eyeball. vtk S rfa Ce
# Skin.vtk u

> skull_bone.vtk
» Information

\
~ Display | \

Visible !
Selected:
Clip:

Slice Intersections Visible:
v?}atena?(‘Properties

Color:

Opacity: 0.42 %
Ambient: e 0.00 [
Diffuse: _—1.00
Specular: ———0.00 |

Power S———TEE
Backface Culling: ¥
Preview: pi

Presets:| |

» Scalars

~ Clipping |
Clipping Type: & Union ® (9 Intersection

~ Data Probe

[
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3D Visualization

@ Modules: @ Models N DA I A =2 I R

& -~ Uncheck the option
o clipping and lower the

= Scene

®

= left_eyeball vik

-+ opacity of the White Matter

= optic_tract_R.vtk

= right_eyeball. vtk S rfa Ce
# Skin.vtk u

> skull_bone.vtk
» Information

\
~ Display | \

Visible !
Selected:
Clip:

Slice Intersections Visible:
v?}atena?(‘Properties

Color:

Opacity: 0.42 %
Ambient: e 0.00 [
Diffuse: _—1.00
Specular: ———0.00 |

Power S———TEE
Backface Culling: ¥
Preview: pi

Presets:| |

» Scalars

~ Clipping |
Clipping Type: & Union ® (9 Intersection

~ Data Probe

[
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®

3D Visualization

) £a |Modules:

@ 3DSlicer

| Help & Acknowledgem

= Scene
= left_eyeball.vtk
= optic_chiasm.vtk
= optic_nerve_L.vtk
= optic_nerve_R.vtk
» optic_tract_L.vtk
= optic_tract_R.vtk
= right_eyeball.vtk
» Skin.vtk
< skull_bone.vtk

» Information

~ Display
Visible:
Selected:
Clip:

Shgwmers?g\cns Visible: ¥

aterial Properties

Color:

e Models sl em A A I @A & A/ R ol 4 » @ Re

The intersection of the

white matter surface with
the 2D anatomical slices
appear in the 2D view

Opacity:

0422

Ambient:

0.00 |+
1.00 ¢

Diffuse:

0.00 (=

Specular:
Power:

Backface Culling: ¥
Preview: fe

» Scalars
~ Clipping
Clipping Type:

~ Data Probe

-[1.0 2 A: -69.00

Presets:

@ Union @ (®, Intersection
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3D Visualization

®

& |Modules: L@ Models == (% ™ o~ @B e o A .

s .  Select Conventional Layout
. from the layout manager,
=+ and turn off the visibility of

= optic_nerve_R.vtk

= Scene

= optic_tract_L.vtk

-pesdi the coronal slice in the

< skull_bone.vtk

green viewer.

~ Display

Visible:

Selected:

Clip:

Slice Intersections Visible: ¥

v Material Properties

Color:

Opacity: )

Ambient:
Diffuse:

Specular:
Power:

Backface Culling: ¥
Preview: fe

» Scalars

~ Clipping
Clipping Type: ) Union @ (@) Intersection

~ Data Probe

©2012-2014, NA-MIC ARR olige oo



®

3D Visualization

800 3D Slicer 4.1.0-rc1-2012-03-15
ga &3 |Modules: . [@Welcome to Slicer =00 INP O el s (o |
ox i ... -
P ole e
Q 30Slicer H*L GlelelE]
A s b2
Welcorps

Click on the top left corner
of the 3D viewer to display
the 3D control windows

Click on A (Anterior) to
display an anterior view of
the 3D models

[~ Data Probe P )
@
L
F
B
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3D Visualization

®

8.00, 3D.Slicerd,102rc122012503515
ga & |Modules: -, [@Welcome to Slicer DR ERGNEAN - I

@ 3DSlicer

Welcome

| @& Load DICOM Data || oy Load Data |
[ @ Customize Slicer || @ Download Sample Data |
[» About

[» The Main Window ]

[» Loading and Saving

[» Display

[» Mouse & Keyboard |

| » Documentation & Tutorials

[» Acknowledgment |

[~ Data Probe

W
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hemispheric_white_matter.vtk
left_eyeball.vtk

optic_chiasm.vtk -
optic_nerve_L.vtk

optic_nerve_R.vtk a =
optic_tract_L.vtk

optic_tract_R.vtk

right_eyeball.vtk

Skin.vtk

skull_bone.vtk

grayscale
SceneViewToplevelHierarchyNode1
Default Scene Camera1l

Default Scene Camera2 u
Default Scene Camera3

Default Scene Camera4

Default Scene Camerab

Default Scene Camera6

Axial

Sagittal

Coronal

Master Scene View
Default Scene Camera7
Default Scene Camera
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Saving a Scene

8no 3D Slicer 4.1.0-rc1-2012-03-15

&a [Modu

s .. oelect File > Save from the
Vel main menu

@ Load DICO
@ Customize Slicer || @ Download Sample Data

[» About

[» The Main Window

[» Loading and Saving

| » Display

[ » Mouse & Keyboard

| » Documentation & Tutorials

[ » Acknowledgment

[~ Data Probe

T

©2012-2014, NA-MIC ARR Slide 60



Saving a Scene

3D Slicer 4.1.0-rc1-2012-03-15

2\ Welcome to Slicer =00 NP O e«ld 2 ;‘ t -

ox i

2a &a IModules: -,

@ 3DSlicer

Welcome
sy Load DIC(_)M Data || [reuiy Load Data

[ & Ci i 800 i Save Scene and Unsaved Data

(bahbout v Node Name Node Type | Node Status File Format File Name Data Directory

| » The Main Window| | 1 v (Scene Description) (SCENE)  Modified + 3DHeadScenejmrml \ﬁ/Users/spu]o\/data/iiDV\suahzationData/3DHeadDa!

[WM 2 hemispheric_white_matter.vtk Model Not Modified | Poly Data (.vtk) o \hemispheric_wh]te_maner.vtk[ﬁ/Users/spujo\/datalaDVisuaiizationDaIa/:iDHeadDat

e ] left_eyeball.vtk Model Not Modified \Poly Data (.vtk) & \Ieft,eyeball.v!k |ﬁ/Userslspujo\ldatalaDV\suahzalionData/SDHeadDat

[» Display 4 [ optic_chiasm.vtk Model Not Modified [Poly Data (.vtk) |+ |optic_chiasm.vtk |9 /Users/spujol/data/3DVisualizationData/3DHeadDat,

[» Mouse & Keyboar( 5 | optic_nerve_L.vtk Model Not Modified [Poly Data (.vtk) |+ |optic_nerve_L.vtk |9 /Users/spujol/data/3DVisualizationData/3DHeadDat{
B ) | E— D)

[> Documentation & petination for all selected: |9 /Users/spujol/data/3DVisualizationData/3DHeadData |

[» Acknow\edgmem;

The Save Scene and Unsaved Data lists
all the elements of the Slicer Scene

| » Data Probe |

-

©2012-2014, NA-MIC ARR

Slide 61



Saving a Scene

3D Slicer 4.1.0-rc1-2012-03-15

@ s0ticer

ga & |Modules: - [@Welcome to Slicer

Welcome

COINP®e@ 2~ |Hie t-
1

@®

| 2% Load DICOM Data || a5y Load Data
[ #C 800 i Save Scene and Unsaved Data
| » About . .
> | v Node Name Node Type | Node Status File Format Data Directory
| » The Main Window ¥ (Scene Description) (SCENE)  Modified + myNewScene.mrml 9 /Users/spujol/data/3DVisualizationData/3DHeadDat;

[» Loading and Savir
|» Display

[» Mouse & Keyboar(

left_eyeball.vtk

AN =

optic_chiasm.vtk
5 | optic_nerve_L.vtk

hemispheric_white_matter.vtk Model

Not Modified |Poly Data (.vtk) ¢ |hemispheric_white_matter.vtk | ¥ /Users/spuijol/data/3DVisualizationData/3DHeadDat|
Model Not Modified |Poly Data (.vtk) ¢ |left_eyeball.vtk 9 /Users/spujol/data/3DVisualizationData/3DHeadDat,
Model Not Modified [Poly Data (vtk) | #|optic_chiasm.vtk 9 /Users/spuijol/data/3DVisualizationData/3DHeadDat|
Model Not Modified \Po\y Data (.vtk) o ]optic,nerve,LAvtk

9 /Users/spujol/data/3DVisualizationData/3DHeadDat;,
/ &2

il

D)

[ » Documentation &

| » Acknowledgment

Destination for all se\ecled:\ﬁ/Users/spujo\/dala/3DVisua\izationDala/SDHeadData

Rename the scene myNewScene.mrmil

and click

on OK

|~ Data Probe
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Saving a Scene

eNO
&a [Modu

s .. oelect Slicer-> Exit to close the I
Vel scene ‘myNewScene.mrml’, and

@ Load DICO

oo exit Slicer

» About

3D Slicer 4.1.0-rc1-2012-03-15

» The Main Window
» Loading and Saving
» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

~ Data Probe

L
F
B
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Scene Restore

Modi

» .. Restart Slicer and select File->Load
Welc Scene from the main menu

= Load DIC _
#: Customize Slic (,Dwnl ad Sample Data
» About
» The Main Window
» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

~ Data Probe

L
F
B

None RAS: (125.0, -125.0, 1.0),
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Scene Restore

Modi

» .. Restart Slicer and select File->Load
Welc Scene from the main menu

= Load DIC _
#: Customize Slic (,Dwnl ad Sample Data
» About
» The Main Window
» Loading and Saving

» Display

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

~ Data Probe

L
F
B

None RAS: (125.0, -125.0, 1.0),
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Scene Restore

3D Slicer 4.1.0-rc1-2012-03-15

e t-

& |Modules: ., [@Welcome to Slicer " 00 INPO el s

@ 3DSlicer
Welcome

| =% Load DICOM Data oy Load Data |
( # Customize Slicer @ Download Sample Data |
8No Open
[» About Look in: £3/Users/spujol/...ata/3DHeadData ¢ | & © @ # (1 [E]

A spuic|  Name

| » The Main Window
m 3DHeadScene.mrml

EEE

| » Display

myNewScene.mrml

|
|
| » Loading and Saving |
|
|

| » Mouse & Keyboard

[ » Documentation & Tutorials

[» Acknowledgment

- I EEEEEED

N TR »
File name: |myNewScene.mrml

Files of type: | All (*.mrml *.xml *.xcat) 2] XCancel

~ Browse to the directory where you copied

|~ Data Pr

. the scene, select the file
myNewScene.mrml and click on Open

BNone (
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®

Scene Restore

8006 3D Slicer 4.1.0-rc1-2012-03-15
ga & 2a |Modules: . [@Welcome to Slicer " 00N e s B .g‘ 4~ > B e R |4
. =

@®
@ 3DSlicer

Welcome

| =% Load DICOM Data | oy Load Data |
[ # Customize Slicer || @ Download Sample Data |
[» About

[» The Main Window

|» Loading and Saving

| » Mouse & Keyboard

[ » Documentation & Tutorials

|
|
|
| » Display |
|
J
|

[» Acknowledgment

- The scene myNewScene.mrml appears in
. the viewer

L Nor
F Noric;
BNone ()
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‘ﬁ' Conclusion

This tutorial guided you
through the basics of data
loading and interactive 3D
visualization of volumes
and 3D surface models in
Slicer4.

Contact: spujol@bwh.harvard.edu
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‘ﬁb Slicer Community

e Www.slicer.org

* Mailing lists:
slicer-user@bwh.harvard.edu
slicer-devel@bwh.harvard.edu
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